Menu ▾ ▴

#10 can't make it work

open
6
2003-07-19
2003-07-15
No

I've installed itms on my intranet server, changed
config.php accrodingly (I hope) and tried to run it.
apache's error log intially printed the error:
Undefined variable: messages in
/data/www/intranet/itms/error_handler.php on line 60.
adding the line: include("toolbox.php") (I think)
solved the problem. Now there is another error: PHP
Fatal error: Cannot redeclare convert_date()
(previously declared in
/data/www/intranet/itms/toolbox.php:33) in /data/ww
w/intranet/itms/toolbox.php on line 33. Here I get
stopped and I don't know how to solve it.

Discussion

1 2 > >> (Page 1 of 2)
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-16

    Logged In: YES
    user_id=222242

    VRKid (Paolo) -
    I believe your second error is due to adding toolbox.php to be
    included in error_handler.php.
    Please revert your changed versions back to the original
    copies and try the following for line 60 in error_handler.php:
    FROM->
    $messages = make_clean($messages);
    TO->
    $message = make_clean($message);

    Let me know if your first error goes away after this change,
    thanks,
    -Matt

    BTW: What version of PHP are you running?

     
  • Paolo Supino

    Paolo Supino - 2003-07-16

    Logged In: YES
    user_id=16945

    Hi
    thanx. Yes the error did go away. Now there are 2 more:
    Undefined variable: user in
    /data/www/intranet/itms/login.php on line 317, PHP Notice:
    Undefined variable: pass in
    /data/www/intranet/itms/login.php on line 317.

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-16

    Logged In: YES
    user_id=222242

    Ok, thanks for the update,
    Can you let me know some info about the server you are
    running ITMS on?
    Specifically:
    PHP Version, Apache Version, Operating System version, etc...

    Also, in php.ini there is a Register Globals Directive, the
    default value for newer versions of PHP is 'off', can you
    verify that this is the case in your version?

    thanks,
    -Matt

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-16

    Logged In: YES
    user_id=222242

    Alright, I've got something for you to try:

    In login.php, you will see lines 58 and 59 call the extract
    function.
    below those calls add these two lines:
    extract($_COOKIE);
    extract($_SESSION);

    I think that should do the trick, I'm not sure why it is
    giving you errors, I know I tested my registered globals fix
    on my linux box.

    Anyways, let me know how this goes.
    thanks,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-17

    Logged In: YES
    user_id=16945

    Hi Matt

    Sorry I thought I had post the versions of the software
    <grin>
    Here we go:
    OS: Linux (Slackware 9)
    web server: Apache (1.3.27) compiled with web_dav,
    mod_security and php statically (call me a weirdo, but I
    like to compile things statically)
    PHP: 4.3.2 (latest and greatest stable).
    apache+modules+php were compiled by me.
    my php.ini indeed has the global register set to off (are
    the entries in php.ini case sensitive?).
    Did the 2 additions from below and here is what I get in the
    error log now:
    [Thu Jul 17 12:54:09 2003] [error] PHP Notice: Undefined
    variable: _SESSION in /data/www/intranet/itms/login.php on
    line 61
    [Thu Jul 17 12:54:09 2003] [error] PHP Warning: extract():
    First argument should be an array in
    /data/www/intranet/itms/login.php on line 61
    [Thu Jul 17 12:54:09 2003] [error] PHP Notice: Undefined
    variable: user in /data/www/intranet/itms/login.php on line 319
    [Thu Jul 17 12:54:09 2003] [error] PHP Notice: Undefined
    variable: pass in /data/www/intranet/itms/login.php on line 319

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-17

    Logged In: YES
    user_id=222242

    Paolo,
    Thanks for your patience with this, and thank you for your
    willingness to help me debug this problem.
    What I am going to do is this:
    When I get home tonight I will upgrade my PHP verison on my
    linux box to 4.3.2 and see what I get as far as errors.
    That way we are on the same page and I can attempt to fix
    the problem without having to have you try 50 different code
    changes before we figure out the best way to fix the problem.
    I'll continue to provide you with updates on my progress.

    thanks again,
    -Matt

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-18

    Logged In: YES
    user_id=222242

    Ok, I've upgraded by RH Linux PHP to 4.3.2 and I don't get
    any of the errors you've mentioned. When I configure my PHP
    I use the following command:
    ./configure --with-mysql --with-apxs=<path to apache>/bin/apxs

    I believe this is the DSO (non-static) method of compiling
    PHP, but I don't know enough about static vs. dynamic
    installs of PHP to know if this is where the problem you are
    experiencing lies.

    I also verified that my register_globals directive is set to
    Off in my php.ini file, so I know that should work. (I don't
    think they are case-sensitive, but I never had to modify my
    php.ini for my needs so I'm not totally sure)

    So right now I'm stumpped, maybe you could send me the
    output of your phpinfo() function on your server, create a
    file with the php tags surrounded by the phpinfo function
    like this:
    <?php
    phpinfo();
    ?>

    I can compare it against mine and see if I can notice the
    problem, otherwise if you have any ideas, I'm all ears.

    thanks,
    -Matt

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-19
    • labels: --> Install Problem
    • priority: 5 --> 6
    • assigned_to: nobody --> mpalmerlee
     
  • Paolo Supino

    Paolo Supino - 2003-07-20

    Logged In: YES
    user_id=16945

    Hi Matt
    going through phpinfo output I noticed that it claims that
    the mysql api was 3.23.49 and the version of mysql running
    right now is 4.0.13. might it be that this difference is the
    one causing the problem?

    Paolo

    PS - I also sent you a private email concerning this issue

     
  • Paolo Supino

    Paolo Supino - 2003-07-20

    Logged In: YES
    user_id=16945

    Hi Matt

    just recompiled php (4.3.2) and apache (1.3.28) the same way
    but this time letting him find mysql 4.0.13 (at least that's
    what phpinfo claims now) but the same problem persists. Any
    ideas (maybe downgrading would solve this?

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-21

    Logged In: YES
    user_id=222242

    Hi Paolo,
    I use MySQL version 3.23, but I don't see why the MySQL
    version would cause the errors you are getting.
    What options to you supply on the command line when
    configuring PHP to compile?

    i.e. when I compile PHP I use the following:
    ./configure --with-mysql --with-apxs=<path_to_apache>/bin/apxs

    thanks,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-22

    Logged In: YES
    user_id=16945

    Hi Matt
    you compile it as a DSO, I prefer to compile it statically
    into apache. My configure looks like this:
    ./configure --sysconfdir=/etc
    --sharedstatedir=/usr/local/share --localstatedir=/var
    --with-apache=../apache_1.3.28 --with-config-file-path=/etc
    --with-openssl --with-mysql=/usr/local --with-pgsql=/usr/local

    I also have the output of phpinfo(), but I don't want to
    post it here. How can I send it to you?

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-22

    Logged In: YES
    user_id=222242

    Send me an email at: mpalmerlee@users.sourceforge.net
    with the phpinfo attachment, if you have problems sending to
    that address let me know.
    When I look at some of the manuals online it shows one
    argument for configure being:
    --activate-module=src/modules/php4/libphp4.a
    Do you need to have an activate-module line? I'm not by any
    means a PHP configuration guru, but if other php stuff works
    on your system then obviously PHP is working correctly.

    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-22

    Logged In: YES
    user_id=16945

    Hi Matt

    Yes. I do have the activate parameter in apache's
    configuration. php wouldn't be compiled in if it's mentioned
    as a parameter in apache's configure's command line. I also
    sent you the phpinfo() output.

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-22

    Logged In: YES
    user_id=222242

    Ok, Paolo, thanks for the email, I have to wait until I get
    home to compare your phpinfo to mine, meanwhile....

    I had you try adding extract($_COOKIE); &
    extract($_SESSION); in login.php before, can you remove the
    call to extract($_SESSION); and leave in the
    extract($_COOKIE); and see if your errors go away?

    thanks for your patience on this,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-22

    Logged In: YES
    user_id=16945

    Hi Matt
    Didn't help :( I still get:
    [Wed Jul 23 04:15:47 2003] [error] PHP Notice: Undefined
    variable: user in /data/www/intranet/itms/login.php on line 318
    [Wed Jul 23 04:15:47 2003] [error] PHP Notice: Undefined
    variable: pass in /data/www/intranet/itms/login.php on line 318
    [Wed Jul 23 04:15:50 2003] [notice] child pid 13521 exit
    signal Segmentation fault (11)

    Paolo

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-23

    Logged In: YES
    user_id=222242

    One thing I notice different between your phpinfo and mine
    is the variables_order directive, my value is "EGPCS" and
    yours is "GPCS", which from what I've read shouldn't cause
    this undefined variables error, but I guess it's worth a
    try, check out this page:
    http://us2.php.net/manual/en/configuration.directives.php

    If that doesn't change anything, I'll have to re-compile
    apache/php as static like your env. and try to reproduce the
    problem.

    thanks,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-23

    Logged In: YES
    user_id=16945

    Hi Matt
    I did a little mistake. I copied the recommended and not
    the dist one from php's source directory. I now copied the
    dist one and things look better. I don't get the user and
    pass not defined anymore, but I do get a segmentation fault
    on child process.

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-23

    Logged In: YES
    user_id=222242

    Great to hear that those other errors go away, did you
    revert back to the original login.php? (i.e. take out the
    extract($_COOKIE); line I had you put in) If not I think
    that must be the problem.
    I wonder what was different in the recommended php.ini vs.
    the dist php.ini that caused so much trouble?

    Let me know if you still have problems after reverting back
    to the original code,
    thanks,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-23

    Logged In: YES
    user_id=16945

    Hi Matt

    I still get segmentation fault after removing the extract
    line that was added.

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-23

    Logged In: YES
    user_id=222242

    Were you always getting the segmentation fault, or was it
    after I was having you change stuff? I'm thinking there must
    be something different either in PHP or ITMS that is causing
    that seg. fault.
    Let me know if there is anything else you can think of that
    might be helpful,
    -Matt

     
  • Paolo Supino

    Paolo Supino - 2003-07-23

    Logged In: YES
    user_id=16945

    Hi Matt
    always. Every problem and doesn't matter which, it printed
    the errors and than seg faulted. I thought that it simply
    was php's way to close things when it gets an error.

     
  • Paolo Supino

    Paolo Supino - 2003-07-23

    Logged In: YES
    user_id=16945

    Hi Matt
    always. Every problem and doesn't matter which, it printed
    the errors and than seg faulted. I thought that it simply
    was php's way to close things when it gets an error.

     
  • Matt Palmerlee

    Matt Palmerlee - 2003-07-24

    Includes php.ini and phpinfo.html files

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.