Menu ▾ ▴

#19 mbsync no longer syncs old Maildir after updating to 1.1.2

1.1.x
invalid
nobody
None
unknown
5
2015-11-08
2015-05-15
No

This bug was reported at https://bugzilla.redhat.com/show_bug.cgi?id=1193063

Description of problem:
After updating to isync-1.1.2-1.fc21 I can no longer sync my mailbox with the following errors:

$ mbsync rh
Reading configuration file /home/contyk/.mbsyncrc
Channel rh
Opening master rh-remote...
Resolving ... ok
Connecting to * (
)...
Opening slave rh-local...
Connection is now encrypted
Logging in...
Selecting master Sent...
Selecting slave Sent...
Loading master...
Loading slave...
Maildir error: UID 679379 is beyond highest assigned UID 3312.
Selecting master INBOX...
Selecting slave INBOX...
Loading master...
Loading slave...
Maildir error: UID 679549 is beyond highest assigned UID 425626.

Version-Release number of selected component (if applicable):
isync-1.1.2-1.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:

  1. Upgrade from isync-1.1.1-3.fc21 to 1.1.2-1.fc21
  2. Try to sync your mail

Actual results:
UID errors (see above).

Expected results:
Everything works just like before.

Additional info:
Downgrading back to 1.1.1-3.fc21 resolves the issue for me.

Discussion

  • Fabian Affolter

    Fabian Affolter - 2015-05-15

    It doesn't seem to be packaging bug because several users reported that 1.2.0 is working fine in other conditions.

     
  • Oswald Buddenhagen

    • status: reported --> invalid
     
  • Oswald Buddenhagen

    this is caused by commit 3d5539bb63b7f494f20357d7491d96228a432600.
    it's not a bug, but a feature - it exposes pre-existing problems. see https://sourceforge.net/p/isync/mailman/message/32515785/

     
  • Oswald Buddenhagen

    • Affected: 1.2.0 --> 1.1.x
     

Log in to post a comment.