Issue with data.fs.index.index_tmp
Brought to you by:
tuxmonkey
Issue with data.fs.tmp file causing errors
When adding an issue / updating to the Issue Tracker
the following error is reported, however is still
logged in the data.fs
It appears to be reporting an issue with permisions,
these of course have not been changed? having been
using system without real issue since oct 2004.
"
Zope Error
Zope has encountered an error while publishing this
resource.
Error Type: IOError Error Value: [Errno 13]
Permission denied:
/home/sys/zope/italiks.ucles-red.cam.ac.uk/2.6.2/var/Data.fs.index.index_tmp
"
Am using version 0.5.1 and have not made any changes to
this system or server for months.
Logged In: YES
user_id=1254823
The problem was that the var directory was group root
instead of group httpd - as a result zope (which runs as
httpd) couldn't create a temporary file it needed to rebuild
its internal index. Zope likes to do this every now and then
- but for a site like italiks it has clearly taken a long
time before the first rebuild was required!