Menu ▾ ▴

#379 Responses to 'raw' on lanplus interface greater than 255 bytes are truncated

version-cvs
open
nobody
None
5
2016-04-21
2015-06-29
No

When using a 'raw' command on the lanplus interface (may affect more than this) and the response is greater than 255, the response wraps and only displays <response length=""> modulo 255 bytes.</response>

Discussion

  • Zdenek Styblik

    Zdenek Styblik - 2015-11-04

    Please, can you provide more information? Some (verbose) output could help as well, I suppose.

    Thank you,
    Z.

     
  • Zdenek Styblik

    Zdenek Styblik - 2015-11-05
    • Group: version-1.8.16 --> version-cvs
     
  • William Bryan

    William Bryan - 2015-11-05

    Sorry. In this case the issue was actually within the BMC. However, along the same vein, if the response is > 1024 bytes, you get this error:

    -bash-4.1$ ipmitool -H <ip> -I lanplus -U <user> -P <pass> raw 0x3a 0x0d 0x40 0x03 0x01 0x00 0x49 0x4D 0x50 0x00
    ERROR: Received message with invalid authcode!
    ipmitool: lanplus.c:671: ipmi_lan_poll_recv: Assertion `0' failed.
    Aborted</pass></user></ip>

    I know that this is an issue with the response length, because I modified the maximum response size in the tool to something larger and it worked just fine. Is there a reason the response size is so limited?

     
    • Zdenek Styblik

      Zdenek Styblik - 2015-11-24

      Is there a reason the response size is so limited?

      If there is, I'm fairly sure there is nobody around who knows why. I gave a glance at the code, but I don't see that assert.
      Anyway, please, create patch and I'll give it one more thought then. If I come up empty, I'll be happy to accept it.

      Thank you,
      Z.

       
  • Zdenek Styblik

    Zdenek Styblik - 2015-11-24
    • Group: version-cvs --> version-1.8.17
     
  • Zdenek Styblik

    Zdenek Styblik - 2016-04-21
    • Group: version-1.8.17 --> version-cvs
     

Log in to post a comment.