MySql 5 Redhat AS4

Help
Brian A.
2008-07-07
2013-05-08
  • Brian A.

    Brian A. - 2008-07-07

    When using iodbctest with a mysql 5 driver, I get the following:

    iODBC Demonstration program
    This program shows an interactive SQL processor
    Driver Manager: 03.52.0305.1107
    1: SQLDriverConnect = [iODBC][Driver Manager]/usr/lib/libmyodbc5.so: undefined s
    ymbol: SQLWriteDSNToIniW (0) SQLSTATE=00000
    2: SQLDriverConnect = [iODBC][Driver Manager]Specified driver could not be loade
    d (0) SQLSTATE=IM003

    I ran
    nm /usr/lib/libmyodbc5.so | grep SQLWriteDSNToIniW and the symbol does appear.

    If I run a test using unixODBC's isql I connect w/o a problem.

    Any help would be greatly appreciated.

    Brian A.

     
    • iODBC Maintainer

      I suspect this is because iodbctest is not linked with the -liodbcinst library. I believe the libmyodbc5.so module has a dangling reference to this function and expects it to be resolved by the application. If you recompile iodbctest and include the -liodbcinst library this may resolve your problem.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks