#68 Celestron driver requires >=5.21 HC for hibernate

1.2.X
open
nobody
1
2016-03-20
2016-03-19
No

The 'Celestron GPS' driver in indi-bin 1.2.0+r1013.251~ubuntu15.10.1 from mutlaqja/ppa on Ubuntu Wily allows for a 'Hibernate' property to be set.
This cool feature requires a >= 5.21 Handset to work. On my CGE's 4.10 Handset it prevents INDI from connecting to the mount, only displaying 'timeout' to work with ...
I propose we add a check for this, or at least inform the user.
-- Hans

Discussion

  • Jasem Mutlaq

    Jasem Mutlaq - 2016-03-20

    It doesn't say "Waking up mount failed!" ?

     
    • Hans Lambermont

      Hans Lambermont - 2016-03-20

      The "Waking up mount failed!" does not help. Even the debug level logging does not help to clarify that a 4.10 handset does not accept a wake up from hibernate command.

      cat /tmp/indi_celestron_gps_2016-03-19T19\:28\:51.log
      INFO 169.155884 sec : Session log file /tmp/indi_celestron_gps_2016-03-19T19:28:51.log
      INFO 180.874738 sec : Waking up mount...
      DEBUG 180.874812 sec : CMD (y#)
      ERROR 185.879030 sec : Timeout error
      ERROR 185.879173 sec : Waking up mount failed!
      INFO 201.288003 sec : Debug is disabled.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks