GyachI V1.2.11: Yahoo Captcha Problem

  • Krish

    Krish - 2012-03-18

    I use Gyachi V1.2.11. Since last couple of days, I am unable to log in the yahoo chat rooms. Even after repeated attempts, I see a pop window displaying the following error message,
    "Loading Captcha jph image failed, Try rejoining the chat room"
    Note that similar problem & login issues had led to the release of version 1.2.11 by Ghostler.
    Only way to get around this problem is,
    (1)  enable package debugging (connections -> package debuggin)
    (2) launch Gyachi from the command prompt
    (3) Try joining the room. ignore the pop-up error message
    (4) From the terminal window copy the "http:…….." portion of the text and open this address in a browser.
    (5) Enter the displayed captcha text. (Keep uploading the link until you see the captcha)
    (6) On the correct entry of captcha, one should be able to log in in the chat room.

    I also request enabling the "buddy-images" and calling features in the future versions of Gyachi.
    Unfortunately, Pidgin does support these features but the webcam does not work there.
    Thanks for any help.

  • Islam

    Islam - 2012-03-28

    After a fresh Ubuntu 11.10 install and update, I was looking for Yahoo chat client, just to find out none has the features I needed, finally I tried gyachi to be faced with this captcha issue.. wonderful.. :)

    SO I had to fix it, but to build it from sources I had to go through some other trouble, not exactly the right thread to discuss it but, I had to preceed ./configure and make with CPPFLAGS="-D_FILE_OFFSET_BITS=64".

    Anyway, I found what looks like a fix for this issue, the issue seems to be in the size of the allocated buffer for jpg_image which is sometimes smaller then needed, causing the conversion to fail.

    So increasing the size from 5000 to 9000 (as I tested it) seems to work for now, I suggest using a higher value.

    Hope this helps, thanks.

  • Krish

    Krish - 2012-03-30

    Thanks for your reply ISMED. How exactly do you increase the allocated buffer for jpg_image ?
    Do you have a 32-bit or a 64-bit system ? 

  • Islam

    Islam - 2012-03-31

    You'll have to edit the code and rebuild, I'm using a 32bit system.

    --- gyachi-1.2.11_orig/client/captcha.c 2011-09-03 09:52:56.000000000 +0100
    +++ gyachi-1.2.11/client/captcha.c  2012-03-28 15:12:38.728624831 +0100
    @@ -849,10 +849,10 @@ void handle_captcha(char *ymsg_105) {
        jpg_image = NULL;
        if (jpg_url_ptr) {
            set_captcha_label(captcha_ui, _(" Captcha form parsed.\nFetching the jpg image."));
    -       jpg_image=malloc(5000);
    +       jpg_image=malloc(9000);
            if (jpg_image) {
                *jpg_image = 0;
    -           jpg_size = fetch_url(jpg_url_ptr, jpg_image, 5000-1, NULL, ymsg_sess->cookie);
    +           jpg_size = fetch_url(jpg_url_ptr, jpg_image, 9000-1, NULL, ymsg_sess->cookie);
                set_captcha_image(captcha_ui, jpg_image, jpg_size);
                g_object_set_data(G_OBJECT(captcha_ui), "form_struct", form_struct);
  • henk

    henk - 2012-03-31

    Rebuilding Gyachi with this bigger memory allocation did the trick for me.  Gyachi captcha login works fine again so the workaround to login with my web browser isn't needed anymore. Thanks Ismed for your efforts.
    My system: Debian wheezy.


  • Krish

    Krish - 2012-04-01

    Thanks ISMED & Henk !! Yes,  the yahoo captcha loads on my system (Fedora 14, Linux 2.6.35-14-106, 64bit) without any more problems.  Other two issues are not being able to load the buddy icon images and voice chat (out of yahoo rooms) with friends does not work. These are not too important. Hope Ghostler can fix them in the next release.
    Many thanks again !!

  • gmclark8

    gmclark8 - 2012-04-24

    Thx ISMED & Henk

    I have worked out how to edit the file to increase the jpg buffer size, but do not know how to do the rebuild.
    Any advise greatly appreciated.


  • Krish

    Krish - 2012-04-24

    Hi Gavin,
    I used following steps to solve the Captcha problem

    (1) Download Gyachi V1.2.11 from Sourceforgenet & edit the "client/captcha.c" file using instructions from ISMED (see post 4 above).

    (2) Now compile the code using following commands,
    (i) ./
    (ii) ./configure -enable-maintainer-mode -disable-wine
          If this step generates error, you may have to install the missing packages (usually indicated in the error message).
          Also make sure you have "libv4l-devel" and "libv4l" packages installed on your system.
    (iii) make gyachi.spec
    (iv) make
    (v) make install

    This worked for me on a Fedora release 14, Linux #1 SMP system.
    Hope it helps.

  • gmclark8

    gmclark8 - 2012-04-26

    Thx Krish, but this doesn't seem to work for Ubuntu, and the instructions in the install.txt file says for Fedora/Redhat only.  Can any one advise how I do this for Ubuntu?

  • Mark

    Mark - 2012-08-11

    Hi all,

    Thanks ismed for the fix. Works perfectly on a linuxfromscratch system.


Log in to post a comment.