#900 Please don't hardcode the window icon.

v1.23
closed-fixed
Interface (176)
5
2012-10-13
2012-10-12
No

Thanks for geany.
Could you please not hardcode the window icon? Many icon themes have a 'geany' icon nowadays and currently they are only used on the menu because the window icon is hardcoded.

Best regards.

Discussion

  • Lex Trotman

    Lex Trotman - 2012-10-12

    Not a bug, moved to Feature request. Many themes may set the icon, but not all do, so that case would have to be properly handled on all platforms not simply do not set any icon. Patches are welcome.

     
  • Lex Trotman

    Lex Trotman - 2012-10-12
    • labels: 790033 -->
    • milestone: 3508874 -->
     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-13

    Hi, that's not an issue.
    geany ships its own icons for the hicolor icon theme, which is the default fallback theme. If an icon theme doesn't have a geany icon it automatically uses those.
    So I'm just asking that it doesn't call a specific icon with the full path which is what I'm guessing it does and instead simply call the 'geany' icon.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-13

    For example, yumex (fedora package manager) had this issue and it was solved by this simple commit:
    https://github.com/timlau/yumex/commit/65d349a886742c103cfc7bf230bae76589d69043

    In that case the problem was that it was using 'yumex.png' instead of simply 'yumex'. With that change it now can use the chosen icon theme if it has a yumex icon, otherwise it falls back to the bundled icon.

     
  • Anonymous - 2012-10-13
    • assigned_to: nobody --> codebrainz
    • milestone: --> v1.23
    • status: open --> closed
     
  • Anonymous - 2012-10-13

    Now implemented in Git.

     
  • Anonymous - 2012-10-13
    • labels: --> Interface
    • status: closed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks