Error on trying to boot a new Linux partition

  • Anonymous

    Anonymous - 2007-07-07

    Hi! :-)

    Recently, I installed a Linux at my disk. After installation, I reinstalled GAG and it found the new ext2 partition, but after trying to boot at this partition, I've got the message:
    "sector boot not found or invalid".

    Any ideas? :-)

    • Jerry Heyman

      Jerry Heyman - 2007-07-07

      When you installed Linux, did you specify that the boot loader (grub or lilo) be installed in a partition/file system - or did you default to /dev/hda?  If you used /dev/hda, then unfortunately GAG has overwritten the first stage of the boot and I'm not sure that just pointing to where root is will work.

      • Anonymous

        Anonymous - 2007-07-07

        Hi Jerry! :-)

        THANKS for your help!!!

        I have allready installed here FreeDOS and WinXP. The installation DVD found them and installed GRUB (without asking me, even in the interactive mode), to /dev/hda7 another partition on the same disk, ignoring the MBR.

        The GRUB installation on this (far away from MBR) partition was problematic. Probably a reinstallation of GRUB at MBR solve the problem.

        I just thinking, if I'm able to keep GAG, as my boot loader.
        At this moment, I have reinstalled GAG, but although it sees the Linux boot partition, I'm getting this error message (booting at my other OSes are without problems).

        THANKS AGAIN!!!
        Giorgos. :-)

        • Jerry Heyman

          Jerry Heyman - 2007-07-07


          You mention /dev/hda7 - this would be a filesystem within the extended partition.

          I do not remember if GAG understands extended partitions (I'm running 4.4 as I haven't had a need to upgrade).
          If it does, make sure that you are pointing to the correct filesystem within the extended partition.  If it doesn't, then this is the problem.

          Installing GRUB on the MBR will eliminate GAG completely.  You should be able to program GRUB to
          boot all your different OSes also, but it's not as easy to accomplish as using GAG is...

          Good luck,


    • Anonymous

      Anonymous - 2007-07-09

      Hi Jerry! :-)

      THANK YOU VERY MUCH for your help!!!

      After A LOT of searching, I realized that it was a BIOS related error!

      My BIOS (6yo) can't properly recognize my IDE 230GB disk. Elite hasn't any BIOS updates and Ontrack utility (from WD site) for LBA support in older BIOSes, worked for me ONLY for 1 OS installed at disk.

      Seems like I have to buy a PCI hard disk controller (not a PCI express, since I don't have such slots) :-) , which it comes with its own BIOS (bypassing motherboard BIOS).

      Meanwhille, I connected as 2nd, an older hard disk (10GB) and I installed openSUSE there.

      GAG and GRUB worked properly. I'll keep GRUB for a while (just curiosity) and then I'll reinstall GAG (=my favourite one)! ;-)

      THANKS AGAIN for your help!!!
      Giorgos. :-)


Log in to post a comment.