#183 flac -t returns "okay" even though it errors out

closed-fixed
8
2006-11-14
2005-07-24
Anonymous
No

Trying to ensure my flac collection is error-free, but
I found that flac (1.1.1, gentoo distro) signals 'ok'
even when it can't decode the file properly:

$ flac -t filename.flac ; echo $?

flac 1.1.1, Copyright (C) 2000,2001,2002,2003,2004 Josh
Coalson
flac comes with ABSOLUTELY NO WARRANTY. This is free
software, and you are
welcome to redistribute it under certain conditions.
Type `flac' for details.

filename.flac: *** Got error code
0:FLAC__STREAM_DECODER_ERROR_STATUS_LOST_SYNC
filename.flac: ok
0

Discussion

  • Nobody/Anonymous

    Logged In: NO

    Sorry, forgot to include an email address: flacbug@benizi.com

    Also, I wanted to mention that I had encoded these flac
    files with the "-V" and "--delete-input-file" options,
    making this particularly annoying. (The safety net of "-V"
    was illusory.)

    As a temporary workaround, I'm using (under the assumption
    that good files print no errors under "--silent"):
    flac -st filename.flac 2>&1 | grep . > /dev/null
    Return codes are reversed, though. 1 (posix-false) is a good
    file. 0 (posix-true) is a bad file.

     
  • Nobody/Anonymous

    Logged In: NO

    flacbug@benizi.com here.

    Misplaced blame. flac didn't break my files; it was the ID3
    tagger I was using. Stripped the ID3 tags off and everything
    verified correctly.

    BUT, original problem remains: flac -t returns "ok" even
    though it errors out. (And, I guess, also, flac -t doesn't
    skip over ID3 tags? Maybe the ID3 tagger's tags were out of
    spec?)

     
  • Josh Coalson

    Josh Coalson - 2005-09-02

    Logged In: YES
    user_id=78173

    can you try with flac-1.1.2, and also attach a sample FLAC file
    that does this here?

     
  • Josh Coalson

    Josh Coalson - 2005-09-02
    • assigned_to: nobody --> jcoalson
    • status: open --> open-accepted
     
  • Josh Coalson

    Josh Coalson - 2006-11-13
    • priority: 5 --> 8
     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    Logged In: YES
    user_id=78173

    I can't reproduce this, will need a file that exhibits the
    behavior...

     
  • Josh Coalson

    Josh Coalson - 2006-11-13
    • status: open-accepted --> closed-works-for-me
     
  • Benjamin R. Haskell

    Logged In: YES
    user_id=946178

    So sorry for the delay. I tried a couple of times over the
    past year to duplicate this, unsuccessfully, but now I've
    managed to create a test file that exhibits the behavior.
    -- Ben

     
  • Benjamin R. Haskell

    Logged In: YES
    user_id=946178

    Err, can't figure out how to attach something to my comment.
    Uploaded to my server:

    http://benizi.com/buggy.flac

     
  • Josh Coalson

    Josh Coalson - 2006-11-13
    • status: closed-works-for-me --> open-accepted
     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    problem file

     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    Logged In: YES
    user_id=78173

    excellent! got it, will take a look. also attaching here.

     
  • Josh Coalson

    Josh Coalson - 2006-11-14

    Logged In: YES
    user_id=78173

    ok, fixed in CVS.

     
  • Josh Coalson

    Josh Coalson - 2006-11-14
    • status: open-accepted --> closed-fixed
     

Log in to post a comment.