#38 Problem with “Zend Optimizer” + “ffmpeg-php”

open
5
2007-06-05
2007-06-05
Anonymous
No

Hello,

I have dedicated server with OS "FreeBSD 6.1" installed. I am using "PHP5" with "Zend Optimizer". I have asked my support to upgrade "PHP5", "ffmpeg" and "ffmpeg-php" to the latest versions but it does not fix bug.

After installations "ffmpeg-php" from ports (or even from sources) any simple script even <?php echo "test"; ?> generates the same error message: Segmentation fault (core dumped).

The support finds out that there is problem with "Zend Optimizer" and "ffmpeg-php". When they uninstall "Zend Optimizer", "ffmpeg-php" was working properly.

Could you please give me any suggestions hot wot fix this bug?

Here is php.core generated after executing any PHP script:
$ gdb /usr/local/bin/php php.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.3
Reading symbols from /lib/libm.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.4
Reading symbols from /usr/local/lib/libxml2.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /usr/local/lib/libiconv.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/libz.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.3
Reading symbols from /usr/local/Zend/lib/Optimizer-3.2.8/php-5.2.x/ZendOptimizer.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/Zend/lib/Optimizer-3.2.8/php-5.2.x/ZendOptimizer.so
Reading symbols from /libexec/ld-elf.so.1...(no debugging symbols found)...done.
Loaded symbols for /libexec/ld-elf.so.1
#0 0x00000000 in ?? ()
(gdb) bt
#0 0x00000000 in ?? ()
#1 0x29bcb2d8 in ?? () from /usr/local/Zend/lib/Optimizer-3.2.8/php-5.2.x/ZendOptimizer.so
#2 0x29cfbddc in extension_version_info () from /usr/local/Zend/lib/Optimizer-3.2.8/php-5.2.x/ZendOptimizer.so
#3 0x2824e830 in ?? () from /libexec/ld-elf.so.1
#4 0x00000000 in ?? ()
#5 0x2824e3d8 in ?? () from /libexec/ld-elf.so.1
#6 0x2824e3d8 in ?? () from /libexec/ld-elf.so.1
#7 0x2824e3d8 in ?? () from /libexec/ld-elf.so.1
#8 0xbfbfe998 in ?? ()
#9 0x29ccc51c in ?? () from /usr/local/Zend/lib/Optimizer-3.2.8/php-5.2.x/ZendOptimizer.so
#10 0x2824d018 in tls_dtv_generation () from /libexec/ld-elf.so.1
#11 0x2824e3d8 in ?? () from /libexec/ld-elf.so.1
#12 0xbfbfe998 in ?? ()
#13 0x2823508e in elf_hash () from /libexec/ld-elf.so.1
Previous frame inner to this frame (corrupt stack?)
(gdb)

With best regards

Vitali Simsive

Discussion


Log in to post a comment.