patch (applies to ver 5.2, 5.4 and 5.5)