#638 latest CVS crashes with a bug report

v1.0 (example)
open
nobody
None
5
2013-10-21
2013-10-20
guybrush
No

Hello to everyone! I've just experienced a strange behaviour from the latest CVS of esniper. I've just built it as I've always done with each new version I've built (statically linked excutable cross compiled for use on a mips router). Just from the beginning, I've noticed that the executable was bigger than it used to be but I didn't put much attention on it.
Today is the second or the third day of use but it is the first time I've used it with an auction file because I had a lot of auctions to place bids on.
Everything went fine (I've also won one of them) till this afternoon when esniper has crashed with the attached bug report.
What's even stranger is that esniper totally crashed. I had other auctions to place bids on but the process has simply disappeared from the list of the active processes. I have lost an auction I had probably won because esniper wasn't running and I didn't know that (this isn't the problem, not at all!) and I've had to restart it for the remaining auctions.
I've to add that I'm running esniper on 3G connection but I think that a connection drop or whatever else linked to the connection couldn't justify a complete crash, couldn't it?
Could this behaviour be linked to a bug or to something else (completely different like something linked to my particular scenario)? Thanks in advance for your replies.

1 Attachments

Discussion

  • Bodo

    Bodo - 2013-10-20

    eBay might have changed something again.
    The attached page looks similar to the article description page with a message "You didn't win this auction." Maybe esniper can no longer find out the bid result.

    I don't know if esniper should continue to work after a bug report or if it will exit in this case. (I would have to check the source.)
    If the program really crashed, did it produce a core file?

     
  • guybrush

    guybrush - 2013-10-21

    Hi and thanks for your reply. First of all, being the Linux setup on the router very basic and with a very old kernel (2.6.8.1), I don't think it provides a core file with the memory dump at the crash stage so I haven't one.
    That said, I'd like to point out that I was going to win that auction (my bid was much higher than the auction closing price) but the bid wasn't simply placed I think because esniper crashed in the pre-bid stage and it crashed for sure because when I checked it wasn't no longer running and I've also lost a couple of auctions which ended in the meantime (according to the auctions closing prices I had probably won them too should esniper be still running).
    I hope that things are clearer now but don't hesitate to ask for any necessary clarifications. Thanks again and have a good day!

     
  • guybrush

    guybrush - 2013-10-21

    Just a doubt. As said too, I'm on 3G connection so a connection drop is more likely to happen. What does happen if esniper tries to connect to make his pre-bid checks and it doesn't find an active connection? Could it terminate by itself in such a scenario? This is the only explanation I can think of but how could it generate the bug report saying that I had lost the auction if it hasn't an active connection underneath? I don't think it could be possible.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks