#388 Crash after upgrade to Ubuntu Precise

2.6
open
nobody
4
2014-11-01
2014-08-10
John Bradshaw
No

Upgraded OS from Ubuntu 10.04 LTS to 12.04 LTS per http://wiki.linuxcnc.org/cgi-bin/wiki.pl?UpdatingTo2.6

Linuxcnc 2.6 now crashes a few seconds after the GUI appears.

Core dump and crash reports attached... in the RTAI module the messages about /etc/udev/rules.d/99-rtai.rules were due to the old 10.04-based package which I removed then installed linuxcnc 2.6 using apt-get... don't think it's related to the crash.

1 Attachments

Discussion

  • John Bradshaw
    John Bradshaw
    2014-08-10

    Addring file...

     
  • The wiki page linked in this bug report does not recommend an upgrade from Ubuntu 10.04 Lucid to Ubuntu 12.04 Precise.

    It describes how to upgrade an existing Ubuntu Lucid install from LinuxCNC 2.5 to LinuxCNC 2.6 (without updating Lucid to Precise), and it describes how to make fresh installs of Ubuntu Precise and Debian Wheezy for installing LinuxCNC 2.6 on.

    Updating "Lucid + LinuxCNC 2.5" to "Precise + LinuxCNC 2.6" is not a well tested path, and there are probably lurking issues (like you ran in to) that must be resolved.