#64 It's not supported in FF4.01

open
nobody
None
5
2011-05-03
2011-05-03
Anonymous
No

FF update reminder keeps telling me it will be disabled if upgrade to Firefox 4.0.1.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-05-13

    You can edit install.rdf (and maybe ec2gui.rdf) to change the maxVersion to 4.0.*:
    See here:
    http://kb.mozillazine.org/Editing_an_add-on_to_change_its_compatibility

    While you are making changes, you can make a few more to update ElasticFox:
    Fix background transparency:
    http://dirty-code.blogspot.com/2011/03/problems-with-elastic-fox-in-ff4.html

    Add support for new EC2 instance types:
    http://dirty-code.blogspot.com/2010/11/adding-support-for-new-instance-types.html

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-05-13

    I have made a new version of this XPI with these fixes:
    https://sites.google.com/site/pascalcula/downloads

    I would be delighted if someone on the official team folded in these changes

    (The UI colors fix is a bit of a hack specific to GTK dark theme on Linux, so it would be nice to get a proper cross-platform fix for that in there.)

    Download page:
    https://sites.google.com/site/pascalcula/downloads

    Direct file download:
    https://sites.google.com/site/pascalcula/downloads/elasticfox-1.7.000116.xpi.bin?attredirects=0&d=1

    Release notes:
    ElasticFox 1.7 for Firefox 4.0.*,
    with support for 2011 EC2 instance types
    and with menu-color fix for Linux GTK Dark theme.
    Note: For Security protection, you must remove ".bin" suffix after downloading, and then open in Firefox to install.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-05-17

    Thanks for this fix while we wait for the official fix. It works!

     
    Last edit: Anonymous 2017-08-25

Log in to post a comment.