Run error in eclipse 3.1.0

Help
2005-08-05
2012-12-06
  • Oliver William NB

    Hi - I've just been trying out the Haskell plugin as it seems an IDE would be great to work with to learn a language, but not common at all for this kind of language!

    I downloaded the newest 3.1.0 eclipse and tried running a simple "hello world" Haskell program, it resulted in this error popping up in a dialog box:

    'An internal error occurred during: "Launching"'

    I'm not quite sure where to find the logfile corresponding to this, I looked under the .metadata tree, but I couldn't find anything relavant.

    Keep up the your great work!

    Thanks,
    Oliver

     
    • Leif Frenzel

      Leif Frenzel - 2005-08-06

      Hi Oliver,

      thanks for the feedback. Could you describe more in detail what you tried? Did you follow the steps in the cheatsheet?

      Thanks && ciao,
      Leif

       
    • Oliver William NB

      Hi,

      The cheatsheet looks very useful - the difference was in the launch process.

      In the cheatsheet the run 'entry' is created by clicking/running from the context menu of the executable (which works)

      What I was trying was going Run menu ->  Run then clicking on "Haskell application" and clicking "New", which gave this error after I typed in a name and clicked "Run". 

      The entry created by the first method seems to be the same in terms of it's options (the defaults), I can't see any differences...

       
      • Leif Frenzel

        Leif Frenzel - 2005-08-07

        Yes, you're right, they should be equivalent. There seems to be a bug somewhere on the dialog page implementation. I'll see to fix it.

        Thanks && ciao,
        Leif

         

Log in to post a comment.