PyUml not working

Help
2008-05-07
2013-04-16
  • conor fitzgerald

    hello
    I am currently having a problem with PyUml
    When i click on click the first of the four buttons(To start modeling) nothing happens
    If i right click on the project and select "create/Synchroniz UML model" the chosen operation is not currently available

    In the log file the following error appears when i click on the first button

    ******************************************************
    !ENTRY org.eclipse.ui 4 4 2008-05-07 11:53:57.881
    !MESSAGE Failed to execute item pyuml.toolbars.synchronizeModel

    !ENTRY org.eclipse.ui 4 4 2008-05-07 11:53:57.881
    !MESSAGE Failed to execute item pyuml.toolbars.synchronizeModel
    !STACK 0
    org.eclipse.core.commands.NotHandledException: There is no handler to execute for command pyUml.syncModelCommand
        at org.eclipse.core.commands.Command.executeWithChecks(Command.java:484)
        at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:429)
        at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:165)
        at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.java:247)
        at org.eclipse.ui.menus.CommandContributionItem.handleWidgetSelection(CommandContributionItem.java:570)
        at org.eclipse.ui.menus.CommandContributionItem.access$8(CommandContributionItem.java:556)
        at org.eclipse.ui.menus.CommandContributionItem$3.handleEvent(CommandContributionItem.java:546)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3682)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3293)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
        at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
    ******************************************************

    ****I followed the steps when installing*****
    *Got Eclipse for Java Developers (Version 3.3.1 or higher)
    *Download eclipse-pyuml-complete (PyUML-1.0-all-plugins.zip)
    *Unpack the downloaded zip and copy the contents of plugins and features to the plugins/features folder in the Eclipse installation
    *Configure PyDev (choose Python executable in Window->Preferences->PyDev->Interpreter (Python) - I set this to my python executables(C:\Python24\python.exe and pythonw.exe)

    *Add some of my python code to the src directory of the project i created
    *Tried to createUML diagrams
    *Updated all plugins to check if this would fix the issue

    Any help would be gratefully recieved - I have been looking for a good tool for python for UML creation for sometime and I hope that this tool is the correct solution

    Regards
    Conor

     
    • Martin Dittmar

      Martin Dittmar - 2008-05-10

      Hi,
      unfortunately I could not reproduce the problem. For me the plugins works fine with Eclipse 3.3.1 and 3.3.2.

      The NotHandledException is normally thrown when there is no Handler, that means no Connection between a command (executed e.g. by pressing a button) and the java class where is defined what eclipse should do.
      Of course there is a handler defined, so this error is very strange...

      On http://www.eclipsezone.com/eclipse/forums/t108745.html there were also people having this problem... Seems is has something to do with executing a command while a dialog is open??

      They say it might help to use Eclipse 3.4 - it is not yet finished, but there is a Milestone version. But I don't know if pyUML works with Eclipse 3.4...

      Sorry that I cannot give you quick help... One thing you can try is to use Eclipse 3.3.1 instead of 3.3.2 (can be downloaded on http://ftp.wh2.tu-dresden.de/pub/mirrors/eclipse/technology/epp/downloads/release/20071026/eclipse-java-europa-fall2-win32.zip\)
      Also try to re-download the PyUML-Plugin.

      Greetings, Martin

       
    • conor fitzgerald

      Thanks for the suggestions

      I tried Eclipse 3.3.1 and PyUml but this did not work
      If i develop a solution to this problem,i will share it here

      Regards
      Conor

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks