I've currently installed Epic 0.6.38 into RSA 8.0 (based on Eclipse 3.6). I saw that 0.6.39 was out so I went to update it. When Eclipse tries to update it, it goes to the "Legacy Updater" which tells me it cannot be installed because:
Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
--- Current configuration problems
--- Resulting configuration does not contain the platform.
--- Configuration problems after the operation
--- Resulting configuration does not contain the platform. EPIC (0.6.39) requires feature +"org.eclipse.platform (3.2.0)"
From looking around it appears that this means the plug-in says it requires Eclipse 3.2. Is that correct? I see the main plugin tree was updated Jan 11, is is possible that something got inadvertently set?
The following XML snippet is in feature.xml, and it has always been there:
<import feature="org.eclipse.platform" version="3.2.0" match="compatible"/>
According to Eclipse help, the meaning is "dependent plug-in version must be at least at the version specified, or at a higher service level or minor level (major version level must equal the specified version)."
Given that it has always worked for me, I infer that the "major version level" is the initial "3" in 3.x.y.
What is the version of the org.eclipse.platform plug-in in your installation?
Also note that problems such as this one have been sporadically reported in the past, but never explained.
Here's the contents of the features directory (relative to org.eclipse.platform):
drwxr-xr-x 3 root root 4.0K 2011-01-07 10:56 org.eclipse.platform_3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL
drwxr-xr-x 3 root adm 4.0K 2010-12-21 17:00 org.eclipse.platform_3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
drwxr-xr-x 3 root adm 4.0K 2010-12-21 17:30 org.eclipse.platform_3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L
I don't see 3.2.0 listed, are the versions that are there "compatible"?
I think you should be looking under plugins/* not features/*. They should be "compatible" according to the description I quoted in my previous post, and I am also unaware of any official backwards-incompatible changes in any of the Eclipse APIs. FYI, my plugins/ contains org.eclipse.platform_3.3.101.v200809111700 (which is not 3.2.0 either, but apparently "compatible" enough). Perhaps you should seek further assistance via eclipse.org? It would be also interesting to see whether you encounter the same problem with a new (clean) install of Eclipse.
Got some egg on my face, but more from IBM I think in this case. Turns out that if you install RSA 8.0 as root (which is required if you do the default Installation Manager) then you can only add/apply plugins as root as well.
Turns out this is a "bug" and IBM says that it will be fixed whatever comes after 8.01. Sorry for sounding the alarm.
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.