DEBUG error: Source not found for

2012-07-12
2013-05-20
  • Mauro Monteiro Silva

    Hello All,

    I have installed EPIC version 0.6.44 under eclipse indigo on my ubuntu 10.04 LTS - the Lucid Lynx but I am facing some issues to debug a very simple perl code, I tried with different simple code but always I received the same error. Basically, when I try to start debugging, eclipse open a new tab to me with the following message:

    Source not found for eval.pl

    The installation of the same version under eclipse in a Windows machine worked fine. Has anyone seen this error before?

    Mauro

     
  • Jan Ploski

    Jan Ploski - 2012-07-12

    I've never seen anything like this. Did you install EPIC yourself or did it come from some distribution?

    You can see the command-line used by EPIC to invoke the debugger in the log (workspace/.metadata/.log or Error Log view if you have one) if you enable Debugger console (experimental) in Preferences. Maybe you can troubleshoot it in the shell then. Pay attention to possible difference in environment variables in the shell and in Eclipse.

     
  • Mauro Monteiro Silva

    Hello, first of all, thanks for answering my question.

    I installed it using eclipse (Help -> Install New Software) based on the URL I found on the EPIC site (http://e-p-i-c.sf.net/updates/testing) for version 0.6.x, in fact, I have installed version 0.6.44.

    I noted that when I try to run the debug for my Perl file I receive the following error;

    Plug-in org.epic.debug was unable to load class org.epic.debug.local.LocalLaunchConfigurationDelegate.
    An error occurred while automatically activating bundle org.epic.debug (2172).

    Have you seen this before?

    Mauro

     
  • Jan Ploski

    Jan Ploski - 2012-07-16

    I don't recall seeing this. More details about the activation error (stack trace) might be helpful - you can probably find them in file workspace/.metatdata/.log. Other than that, I would try reinstalling. Is Eclipse also installed by yourself or packaged somehow? If the latter, you might try downloading the "Classic" distribution of Eclipse Indigo and installing EPIC into it (this is in fact what I'm using).

     
  • Mauro Monteiro Silva

    Hello jploski,

    To begin with, thanks for your answer! I installed a Indigo Classic version and it worked fine which is ok for me. I mean, I can use this version to developer using perl. However, it seems some bug in EPIC because my other version is Indigo J2EE with some plugins such as Android, FindBugs, EclEmma and so on. Do you know whether EPIC is supposed to work in Indigo J2EE?

    Mauro

     
  • Jan Ploski

    Jan Ploski - 2012-07-20

    I just checked that EPIC 0.6.44 works for me in Eclipse Indigo J2EE on Debian.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks