How to use plugins

  • Laszlo Zsolt Nagy

      Hi All!

    I have DrPython installed. I see there are cool plugins but I cannot user them. For example, I installed the  CodeCompletion" and "CodeMark" plugins. I have enabled the "CodeCompletion" plugin by default. I assigned the shortcut CTRL+SPACE to <Plugin>:CodeCompletion "Toggle Code Completion". However, when I'm editing a file nothing happens. No matter if I hit CTRL+SPACE or not. I have the same problem with CodeMark too. I setup the shortcuts but nothing happens. What am I doing wrong?

    DrPython: 3.10.13.
    wxPython: 2.6
    Python: 2.4

    Platform: both FreeBSD & Windows XP



    • Franz Steinhaeusler

      Hello Les,

      I have answered already in comp.lang.python.

      The codemarks should work now.
      Code Completition (works only with the '.' key):
      Is enabled? Options => Enable Code Completion is checked?
      Then if you type for example (in a file with the ending .py
      only; if you have a new file, save it to <fname>.py before!)

      wx.<here code completion should appeard>



    • Laszlo Zsolt Nagy

      Hi Franz!

      This is why I love Open Source software. I got this fix within some hours. I could already download 0.0.6 from the SourceForge mirror. However, I still cannot start the plugin. When I start DrPython, I get this:

      Error with: CodeCompletion
      DrPython will not load this plugin.

      Traceback (most recent call last):
        File "C:\Python24\Lib\site-packages\drpython\", line 1245, in InitializePlugin
          exec(compile("import " + plugin, pluginfile, 'exec'))
        File "C:/Documents and Settings/Gandalf/Application Data/drpython/plugins/", line 1, in ?
      ImportError: No module named CodeCompletion

      I have uninstalled and re-installed the plugin so probably this is a problem with my system. I'll kepp you posted. Thank you!


    • Laszlo Zsolt Nagy

      Ok, it works now. I had to uninstall->restart->install->restart. I don't have a clue why. :-)

      CodeCompletion works just fine for me!




Log in to post a comment.