No text areas

Help
2004-06-18
2004-08-08
  • David McCuskey

    David McCuskey - 2004-06-18

    Hello,

    I just installed wxPython 2.5.1.5 panther and DrPython 3.0.4 on my PowerBook G3.

    everything seems to work fine, except for the fact that I can't see a text area on the window. i can open a file, get the dialog box and it will load and i can see the tabs for multiple open files.
    however, the scroll bars/text area seem misaligned in the layout because i can see the scroll bar arrows all bunched together in the upper left and lower left corners.

    just for fun i tried DrPython version 3.0.1 and it had the same problem.

    i ran it using  !/usr/bin/env pythonw. pythonw is a simlink to a framework in MacOSX. i tried the demos for wxPython after installing it and they work fine.

    any ideas other than a bug report?

    thanks,
    david

     
    • Daniel Pozmanter

      Alright, let's see what could be going on.

      Try DrPython 2.4.6.  Does that work?
      How about 3.0.6?

      Can you open DrPython in a console?
      Do you get a traceback on launch?
      How about if you open a new document?

      What happens if you view toggle the prompt or the classbrowser?

      Does resizing the whole window make everything nice and jolly?

      Try the sashwindow in the demo for wxPython.
      How does that look?

      Dan

       
      • David McCuskey

        David McCuskey - 2004-06-27

        By: drpython

        > Alright, let's see what could be going on.

        > Try DrPython 2.4.6. Does that work?

        yes, this drpython 2.4.6 works with wxPython 2.4.2.4. no problems at all.

        > How about 3.0.6?

        no. tried 3.0.7/2.5.1.5 this doesn't work. the traceback is below

        2.4.6 also works with wxPython 2.5.1.5

        > Can you open DrPython in a console?
        > Do you get a traceback on launch?

        i've been starting them from the command line.

        i only get a traceback with with drpython 3.0.4/3.0.7 and wxPython 2.4.2.4
        all of the other combinations are ok.

        > How about if you open a new document?

        (3.0.7/2.5.1.5)
        a new tab gets shown, untitled. if i open an existing document, a new tab is created with document name, but still can't see the text area.

        > What happens if you view toggle the prompt or the classbrowser?

        the prompt splits the screen, but the text input areas are still in the corners of the screen.

        the class browser and text areas can't be seen ( though i can see and move the divider between the two spaces. )

        > Does resizing the whole window make everything nice and jolly?

        nope.

        > Try the sashwindow in the demo for wxPython.
        > How does that look?

        ran it using 2.5.1.5. the sashwindow demo looks fine.

        i took two images of what i was seeing. i sent them (with this email to drpython@users.sourceforge.net)

        ??

        thanks for your help!
        david

        SUMMARY

        === 2.4.6 and 2.4.2.4 work together, no problems

        === 3.0.4/3.0.7 and 2.5.1.5
        windows are still messed up, but the application runs with no tracebacks.

        === TRACEBACK   with 3.0.4/3.0.7 and wxPython 2.4.2.4

        amara:/Applications/drpython davidmc$ pythonw drpython.pyw
        Traceback (most recent call last):
          File "drpython.pyw", line 34, in ?
            import drpython
          File "/Applications/drpython/drpython.py", line 3057, in ?
            app = DrApp(0)
          File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/wxPython/wx.py", line 1951, in __init__
            _wxStart(self.OnInit)
          File "/Applications/drpython/drpython.py", line 3050, in OnInit
            frame = DrFrame(None, 101, "DrPython - Untitled")
          File "/Applications/drpython/drpython.py", line 459, in __init__
            self.mdinotebook = drNotebook(self, -1, wx.DefaultPosition, wx.Size(self.prefs.windowwidth, self.prefs.windowheight), wx.CLIP_CHILDREN)
          File "/Applications/drpython/drpython.py", line 90, in __init__
            self.Bind(wx.EVT_LEFT_DOWN, self.OnFindFocus)
        AttributeError: drNotebook instance has no attribute 'Bind'

        --
        David McCuskey
        david@mccuskey.com
        www.davidmccuskey.com

         
    • Daniel Pozmanter

      Doh!

      Ok.  So 3.x only works with wxPython 2.5.1.5 or higher.  So lets work with that.

      No traceback.  Bummer.

      The pictures don't tell me much I did not know, but thanks.

      This works fine on linux, and on windows.
      Also, other mac users don;t encounter this problem.

      This makes me suspect something odd with your setup.  The other possibility is some odd bug in wxPython that I need to write a work-around for (which is difficult, as a I don't have access to a mac machine to diagnose the problem).

      Try uninstalling every version of wxPython you have.  On linux, wxPython GTK2 2.5.1.5 and wxPython 2.4.x = drpython not working properly.

      Could be something similiar on the mac:
      "NOTE: Just after the source code snapshot for this release was taken a number of far reaching fundamental changes for the wxMac port of wxWidgets were checked in to CVS. Consequently, although most things work very well there are a few known issues with this wxPythonOSX release that were not able to be fixed because those other big changes were in progress. A new release of wxPython will be made when issues resulting from those big changes have been resolved. " - From the wxPython website.

      The 2.5.1.5 release is problematic.   While the Windows release seems fine, the linux release has some major bugs, and apparently the mac release does too.

      This could be an artifact of that.
      If that is the case, then we may have to wait for the next wxPython release on the mac.

      I will see if I can figure out something in the meantime.

       
      • David McCuskey

        David McCuskey - 2004-07-08

        Ok, I uninstalled all of the wxPython packages. I did have two different versions installed and I was really hoping that was going to be the problem.

        I reinstalled the latest wxPython, but unfortunately, I'm still seeing the same thing.

        I guess I'll have to be content with waiting for the new release. Bummer...!

        Thanks for all of your help/insight.

        David

         
    • Daniel Pozmanter

      :) You could submit a bug report to the loverly folks at wxPython/wxWidgets.

      I also had a thought.  Did you try installing wxPython 2.5.1.5 for a different version of Mac OS X than you currently have?  Have you tried uninstalling all python packages, then going from there?

      Have you tried posting to mac-users wxpython lists?
      Maybe somewhere there can try this out, and see if they get the same results (or not).

      Thanks for your patience!

      Dan

       
    • polpo

      polpo - 2004-07-28

      Hello !
      Exact same problem here with wxPython 2.5.1.5 on Mac OS X 10.3.4. Did a uninstall then reinstall nothing changed.

      Interface is bugged with DrPython 3.1.5  but interface of version 2.4.6 displays well.
      Must be a wxpython problem as other wxpython apps do the same (e.g www.gnumed.org).

      Is there a radical change in displaying frames from 2.4.6 to 3.1.5 ?

       
    • Daniel Pozmanter

      Yes, as of 3.0.0, drpython uses wx.SashWindow to display the document, prompt, and classbrowser.

      I know some people ( a fellow with some safari issues with drpython, which turned out to be issues with how safari grabs command arguments ) can get drpython to work just fine, so it stands to reason there is some kind of install issue here, where you need very specific versions of python of wxpython on the mac to get them to work.

      I'll ask around.  Good to know my program isn't the only one.  Perhaps if we find a solution, we should post it somewhere conspicuous.

       
    • Daniel Pozmanter

      Ulf responded.  Here is where his python/wxPython, drpython stuff is:

      INSTALLATIONS:

      I installed this package:

      /Users/uwostner/wxPythonOSX-2.5.1.5-panther-Py2.3.dmg

      THERE ARE TWO (2) EXECUTABLES ON MY SYSTEM:

      EXECUTABLE 1:

      This is a link pointing to a link ...

              /usr/bin/python -> /usr/bin/python2.3   -> 
      /System/Library/Frameworks/Python.framework/Versions/2.3/bin/python
             
      That one is in my PATH.

      It's owned by root, witness:

      -rwxr-xr-x  1 root  wheel  22100 29 May 20:57 
      /System/Library/Frameworks/Python.framework/Versions/2.3/bin/python

      EXECUTABLE 2:

      Again, a link pointing to a link ...

      /usr/local/bin/python -> /usr/local/bin/python2.3  -> 
      /Library/Frameworks/Python.framework/Versions/2.3/bin/python

      That one is owned by me, but is not in my PATH:

      -rwxrwxr-x  2 uwostner  admin  9888 30 Jul  2003 
      /Library/Frameworks/Python.framework/Versions/2.3/bin/python

      DRPYTHON:

      /Users/uwostner/drpython-3.1.5/

      WXPYTHON:

      $dolphin:~ root# find / -iname "wxPython*"

      /Library/Python/2.3/wxPython
      /Library/Receipts/wxPythonOSX-panther.pkg
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/
      wxPythonOSX-panther.bom
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/
      wxPythonOSX-panther.info
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/
      wxPythonOSX-panther.loc
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/
      wxPythonOSX-panther.sizes
      /Users/uwostner/wxPythonOSX-2.5.1.5-panther-Py2.3.dmg
      /usr/lib/wxPython-2.5.1.5
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython/wxPython.h
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython/wxPython_int.h

      What results do you get?
      Also, where did you download wxPython from?

       
    • polpo

      polpo - 2004-07-29

      Looks quite the same here...

      INSTALLATIONS:

      I installed same package:
      wxPythonOSX-2.5.1.5-panther-Py2.3.dmg

      Downloaded from there:
      http://sourceforge.net/project/showfiles.php?group_id=10718

      EXECUTABLES

      In /usr/bin/python I've got:
      lrwxr-xr-x    1 root  admin         9 27 Jun 17:14 python -> python2.3
      lrwxr-xr-x    1 root  admin        72 27 Jun 17:17 python2.3 -> ../../System/Library/Frameworks/Python.framework/Versions/2.3/bin/python
      lrwxr-xr-x    1 root  admin        10 27 Jun 17:16 pythonw -> pythonw2.3
      -rwxr-xr-x    1 root  wheel       122 27 Jun 17:12 pythonw2.3

      In /System/Library/Frameworks/Python.framework/Versions/2.3/bin/

      drwxr-xr-x  6 root  wheel    204  3 Jun 10:18 .
      drwxr-xr-x  9 root  wheel    306  3 Jun 10:17 ..
      -rwxr-xr-x  1 root  wheel    111 13 Sep  2003 idle
      -rwxr-xr-x  1 root  wheel     44 13 Sep  2003 pydoc
      -rwxr-xr-x  1 root  wheel  22100  3 Jun 10:18 python
      -rwxr-xr-x  1 root  wheel  22100  3 Jun 10:18 python2.3

      DRPYTHON:

      /Users/username/drpython-3.1.5/

      FIND "wxPython"

      sudo find / -iname "wxPython*"

      /Library/Python/2.3/wxPython
      /Library/Receipts/wxPythonOSX-panther.pkg
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/wxPythonOSX-panther.bom
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/wxPythonOSX-panther.info
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/wxPythonOSX-panther.loc
      /Library/Receipts/wxPythonOSX-panther.pkg/Contents/Resources/wxPythonOSX-panther.sizes
      /usr/lib/wxPython-2.5.1.5
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython/wxPython.h
      /usr/lib/wxPython-2.5.1.5/include/wx/wxPython/wxPython_int.h

      :-(

       
    • Anonymous - 2004-08-01

      I'm having the same problem using wxPython 2.5.1.5 PythonCardPrototype 0.7.3.1 on OS X panther.  Just wanted to give my two cents.
      Best,
      Joe

       
    • Daniel Pozmanter

      Are you having trouble with pythoncard too, or just drpython?

      Anyway, here is an idea.  Since folks are using 3.1.5, I have posted a modified drpython.py for 3.1.5.

      Just put this in the drpython directory, and run it.

      Post any tracebacks here, and post the debug file (which should show up in your home directory conspicuously named) to the patch, or email it to me at my bluebottle address.  Hopefully, I will be to construct what is going on.

      Follow the instructions on the patch page:
      http://sourceforge.net/tracker/index.php?func=detail&aid=1001605&group_id=83074&atid=568240

       
    • Daniel Pozmanter

      I uploaded a test drpython 3.1.5 file (still named debug).

      It may fix the problem.  If not, I don't know what to do.
      The log worked, but did not tell me anything I could use.

       
    • Daniel Pozmanter

      Thanks to the dogged help of Dominique,
      the drpython mac display error has been quashed!

      I still have some work to do to pinpoint the problem,
      but there is a work around, and it will make its way into the next version of drpython (3.3.2).

       
    • Daniel Pozmanter

      This problem has been solved.  The display issue is fixed in 3.3.2.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks