#753 UnmarshalException in "View Interactions Classpath"

3: Ugly
closed-fixed
7
2015-01-03
2009-04-10
No

DrJava has a "View Interactions Classpath" context menu item if you
right-click on the Interactions Pane (also in the menu bar as
"Tools/Interactions & Console/View Interactions Classpath"). It
displays the class path entries and also updates the detected source
roots in flat-file mode.

Unfortunately, I just noticed that this feature has been broken. I
have verified that it broke in revision 4731 during the major
Master/SlaveJVM refactoring in February.

java.rmi.UnmarshalException: error unmarshalling return; nested exception is:
java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: edu.rice.cs.drjava.model.repl.newjvm.ClassPathManager$1
at sun.rmi.server.UnicastRef.invoke(Unknown Source)
at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(Unknown Source)
at java.rmi.server.RemoteObjectInvocationHandler.invoke(Unknown Source)
at $Proxy0.getClassPath(Unknown Source)
at edu.rice.cs.drjava.model.repl.newjvm.MainJVM.getClassPath(MainJVM.java:439)
at edu.rice.cs.drjava.model.DefaultGlobalModel.getInteractionsClassPath(DefaultGlobalModel.java:400)
at edu.rice.cs.drjava.ui.MainFrame.viewInteractionsClassPath(MainFrame.java:2191)
at edu.rice.cs.drjava.ui.MainFrame$102.actionPerformed(MainFrame.java:2186)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: edu.rice.cs.drjava.model.repl.newjvm.ClassPathManager$1
at java.io.ObjectInputStream.readObject0(Unknown Source)
at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
at java.io.ObjectInputStream.readSerialData(Unknown Source)
at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
at java.io.ObjectInputStream.readObject0(Unknown Source)
at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
at java.io.ObjectInputStream.readSerialData(Unknown Source)
at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
at java.io.ObjectInputStream.readObject0(Unknown Source)
at java.io.ObjectInputStream.readObject(Unknown Source)
at sun.rmi.server.UnicastRef.unmarshalValue(Unknown Source)
... 36 more
Caused by: java.io.NotSerializableException: edu.rice.cs.drjava.model.repl.newjvm.ClassPathManager$1
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.defaultWriteFields(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.defaultWriteFields(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.writeObject(Unknown Source)
at sun.rmi.server.UnicastRef.marshalValue(Unknown Source)
at sun.rmi.server.UnicastServerRef.dispatch(Unknown Source)
at sun.rmi.transport.Transport$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Unknown Source)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(Unknown Source)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(Unknown Source)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

System Properties:
DrJava Version drjava-20090407-r4873
DrJava Build Time 20090407-2208

drjava.debug.port = 4932
java.runtime.name = Java(TM) SE Runtime Environment
sun.boot.library.path = C:\jre1.6.0_14\bin
java.vm.version = 14.0-b10
java.vm.vendor = Sun Microsystems Inc.
java.vendor.url = http://java.sun.com/
path.separator = ;
java.vm.name = OpenJDK Client VM
file.encoding.pkg = sun.io
sun.java.launcher = SUN_STANDARD
user.country = US
sun.os.patch.level = Service Pack 3
java.vm.specification.name = Java Virtual Machine Specification
user.dir = <anonymized user.home>\Desktop
java.runtime.version = 1.6.0_14-ea-b01
java.awt.graphicsenv = sun.awt.Win32GraphicsEnvironment
java.endorsed.dirs = C:\jre1.6.0_14\lib\endorsed
os.arch = x86
java.io.tmpdir = C:\DOCUME~1\&lt;anonymized user.name>\LOCALS~1\Temp\ line.separator = "\u000d\u000a"
java.vm.specification.vendor = Sun Microsystems Inc.
user.variant =
os.name = Windows XP
sun.jnu.encoding = Cp1252
java.library.path = C:\jre1.6.0_14\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\jre\bin;C:\jdk\bin;C:\Program Files\Tools\Windows Resource Kits\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Dev\Perforce;C:\WINDOWS\system32\WindowsPowerShell\v1.0;c:\Program Files\Microsoft SQL Server\100\Tools\Binn\;c:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Haskell\bin;C:\ghc-6.10.1\bin;C:\Program Files\Internet\SSH Secure Shell;C:\Scala2.7.1\bin
java.specification.name = Java Platform API Specification
java.class.version = 50.0
sun.management.compiler = HotSpot Client Compiler
os.version = 5.1
user.home = <anonymized user.home>
user.timezone = America/Chicago
java.awt.printerjob = sun.awt.windows.WPrinterJob
file.encoding = Cp1252
java.specification.version = 1.6
java.class.path = <anonymized user.home>\Desktop\drjava.jar
user.name = <anonymized user.name>
java.vm.specification.version = 1.0
java.home = C:\jre1.6.0_14
sun.arch.data.model = 32
user.language = en
java.specification.vendor = Sun Microsystems Inc.
awt.toolkit = sun.awt.windows.WToolkit
java.vm.info = mixed mode, sharing
java.version = 1.6.0_14-ea
java.ext.dirs = C:\jre1.6.0_14\lib\ext;C:\WINDOWS\Sun\Java\lib\ext
sun.boot.class.path = C:\jre1.6.0_14\lib\resources.jar;C:\jre1.6.0_14\lib\rt.jar;C:\jre1.6.0_14\lib\sunrsasign.jar;C:\jre1.6.0_14\lib\jsse.jar;C:\jre1.6.0_14\lib\jce.jar;C:\jre1.6.0_14\lib\charsets.jar;C:\jre1.6.0_14\classes
java.vendor = Sun Microsystems Inc.
file.separator = \ java.vendor.url.bug = http://java.sun.com/cgi-bin/bugreport.cgi
sun.io.unicode.encoding = UnicodeLittle
sun.cpu.endian = little
java.rmi.server.hostname = 127.0.0.1
sun.desktop = windows
sun.cpu.isalist = pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86

#DrJava configuration file
#Fri Apr 10 00:11:37 CDT 2009
lineenum.enabled = true
key.delete.next = shift DELETE
key.delete.previous = shift BACK_SPACE
find.replace.match.case = false
javadoc.additional.links = [http://drjava.org/javadoc/plt]
quit.prompt = false
open.folder.recursive = true
language.level = 2
recent.files = [<anonymized user.home>\\Documents\\Dev\\Java\\DJ1Class.dj1]
recent.projects = [<anonymized user.home>\\Documents\\Dev\\Java\\LLCTest.xml,<anonymized user.home>\\Documents\\drjava\\drjava.xml,<anonymized user.home>\\Documents\\Research\\Mint\\java-mint\\java-mint.xml,R:\\Concutest\\ClassLoader\\ClassLoader.xml,<anonymized user.home>\\Documents\\Web\\&lt;anonymized user.name>.cs\\teaching\\202\\08-fall\\staff\\exams\\2\\2008\\solution\\graph\\graph.xml]
window.height = 1555
window.width = 1208
window.x = -4
window.y = -4
window.state = 6
doc.list.width = 261
last.dir = <anonymized user.home>\\Documents\\Dev\\Java
last.interactions.dir = <anonymized user.home>\\Documents\\Dev\\Java
dialog.clipboard.history.state = 402 400 399 573
dialog.completeword.javaapi = true
tabbedpanes.state = 1201 1 1201 642
tabbedpanes.detach = true
find.replace.focus.in.defpane = true
new.version.notification = weekly experimental builds
new.version.notification.last = 1239178410921
drjava.survey.notification.last = 1239338306562
drjava.survey.result.last = http://www.drjava.org/submit-usage.php?rev=4873&os.name=Windows%20XP&os.version=5.1&java.version=1.6.0_14-ea&java.vendor=Sun%20Microsystems%20Inc.

Used memory: about 7.71 megabytes
Free memory: about 1.63 megabytes
Total memory: about 9.34 megabytes
Total memory can expand to: about 63.56 megabytes

Discussion

  • Dan Smith

    Dan Smith - 2009-04-13
    • status: open --> closed
     
  • Dan Smith

    Dan Smith - 2009-04-13

    Fixed with rev 4888.

     
  • Dan Smith

    Dan Smith - 2009-04-13
    • status: closed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks