drip-0.8.0pre2 segaults

Help
2001-10-31
2002-11-30
  • Terry Lewis

    Terry Lewis - 2001-10-31

    Hi, i have been working on trying to get drip to work without segfaulting for over a day and still no luck, the first time i compiled and installed drip and avifile 0.6 it worked right up to encoding the actual ripped vob, and then used to just crash without warning at all, like the whole app woul;d disapear, now for some reason i start drip and it crashes constantly and goes into some kind of loop, liek the app keeps trying to respawn itself, i get the following when a crash is invoked: Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

    i have also tried using the backend on its own, and i get many of the following and then follows into a segfault: mpeg3_get_ps_pes_packet: Decryption not available
    i have all the relevent dvd stuff installed since i use xine and that uses the same libs for dvd support. any help would be greatly appreciated, looks like it could be avery cool app!

    MrK
       

     
    • Bruno Thomsen

      Bruno Thomsen - 2002-11-24

      I have the same problem when I click on preferences:
      Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.
      /usr/local/bin/drip: line 6: 24411 Segmentation fault      gnomedrip

      Could it be something with this warning?:
      Gtk-WARNING **: invalid cast from `GtkHBox' to `GnomeDockItem'

      Bax

       
      • Bruno Thomsen

        Bruno Thomsen - 2002-11-24

        btw I use version: drip-0.8.3.1

        Bax

         
        • Jarl van Katwijk

          Could you send me a core file of this crash? And if so, a copy of 'gnomedrip' , so I can have a look at this problem

           

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks