#262 The screen stays black when i launched Xserver

open
nobody
ATI OpenGL (71)
5
2001-10-06
2000-12-15
No

Config:
PII 450 192 MB , Redhat 7.0, ATI Rage 128 Fury 32 MB,
Linux kernel 2.4.0-test11, XFree4.0 CVS 12/12/2000

When I launch the Xserver with module DRI activated, my screen stays black and the process X stop. On my console, only my keyboard works.

Xserver works fine when DRI is desactivated.

Note:
Module DRI works with XFRee 4.0.1 november version.

Discussion

  • Nobody/Anonymous

    I think we have the same problem.
    I can still move the pointer even though I can switch virtual screens, but the screen stays black. But for me, it manifests itself only when I launch a 3D app.

    I will compile my kernel and XFree with egcs 1.1.2 instead of gcc 2.95. Who knows...

    Ookaze

     
  • Gareth Hughes

    Gareth Hughes - 2000-12-16

    If you restart the X server a couple of times, does this help? I've had it take two or three restarts, but this is a Mobility 128 system (my laptop).

     
  • Gareth Hughes

    Gareth Hughes - 2000-12-16
    • assigned_to: nobody --> gareth
     
  • Mellinet stephane

    I solved the probleme with kernel 2.4.0-test12, =>DRI works

    => for me , the problem is module DRM (2.1.0)

    sucess: Chromium, and xscreensaver (module OpenGL)

    not sucess: (XServer is locked with black screen)
    The demo SOF and descent3

    I will try with the latest source.

     
  • Gareth Hughes

    Gareth Hughes - 2001-10-06
    • assigned_to: gareth --> nobody
     

Log in to post a comment.