#836 listitem with xml:id does not get anchor

output: HTML
closed-fixed
XSL (1066)
5
2007-03-13
2006-10-17
oldgrump
No

Using DocBook 5.0b8 and docbook-xsl-1.71.0/html/chunk.xsl

Defining the xml:id attribute to a listitem element
does not result in an <a name="..."></a> tag in the
generated html. It does work if the attribute is
defined for a section or para element.

In DocBook 4.4 defining the id attribute for a listitem
element resulted in its child paragraph having the <a
name="..."></a> tag.

Discussion

  • Robert Stayton

    Robert Stayton - 2007-02-26
    • assigned_to: nobody --> bobstayton
    • status: open --> pending-fixed
     
  • Robert Stayton

    Robert Stayton - 2007-02-26

    Logged In: YES
    user_id=193218
    Originator: NO

    A fix for this issue has been added to the current codebase.
    Please test the fix with the latest snapshot from:

    http://docbook.sourceforge.net/snapshots/

     
  • SourceForge Robot

    • status: pending-fixed --> closed-fixed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks