Running dnx version 0.19.5 on SLES 9 sp3 with Nagios 2.7.
If the line "showNodeAddrs = YES" is un-commented and you attempt to startup the dnxClient binary, it will fail with the following error:
"Starting dnxClient startproc: exit status of parent of /usr/local/nagios/sbin/dnxClient: 245 Failed"