needed it for .NET 1.1

2005-08-03
2013-03-24
  • Kapil Sachdeva

    Kapil Sachdeva - 2005-08-03

    You guys are doing work writing an IL editor but should n't u have built it using .NET 1.1.

    .NET 2.0 is still in beta stage and it is something people running .NET 1.1 would also need.

    Regards
    Kapil

     
    • Petrény Zsolt

      Petrény Zsolt - 2005-08-04

      Hello!

      I'm glad to see that you think this program would be useful for .NET 1.1.
      Actually, it wouldn't be impossible to write it using 1.1 but when I started this project one of my purposes was to learn the new features of the 2.0 Framework and to get familiar with the new version of VS.NET.
      Now the code relies on 2.0 features (especially generics) in many places. These could be rewritten to use the 1.1 syntax and classes but I think it would take quite a lot of time.

      It's true that now you need the 2.0 Framework to be installed on the target computer but the program itself is compatible with the 1.0/1.1 Framework. By this, I mean that you can load 1.0/1.1 assemblies in DILE, you can check the IL code, it should work well.
      Right now I'm writing the debugger part of the program and that will also be 1.0/1.1 compatible but the 2.0 Framework will be needed to run DILE itself.

      So my suggestion is to install the 2.0 Framework - which is freely available - besides the 1.1 Framework and use DILE with the 1.1 assemblies.

      Best regards,
        Zsolt Petrny

       
    • n|m

      n|m - 2006-03-27

      .NET 2.0 it is SAX :)

       

Log in to post a comment.