|
From: Dominic R. <dl...@ed...> - 2012-02-13 15:08:55
|
<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
On 13/02/2012 13:45, Heiko Zuerker wrote:
<blockquote
cite="mid:201...@ww..."
type="cite">
<pre wrap="">Hey,
Quoting Andrzej Odyniec <a class="moz-txt-link-rfc2396E" href="mailto:an...@ma..."><an...@ma...></a>:
</pre>
<blockquote type="cite">
<pre wrap="">Heiko Zuerker wrote:
</pre>
<blockquote type="cite">
<pre wrap="">The addition of cifsutils was in preparation of the upgrade to samba 3.6.
The new samba version doesn't include any of the cifs client tools, that's
why we need that package.
</pre>
</blockquote>
<pre wrap="">
Heiko,
You are right. I did not check carefully the cause. Now I'm wiser, because I
read the sources.
</pre>
<blockquote type="cite">
<pre wrap="">I just checked in the latest samba and an update to cifsutils. Hopefully the
newer version works better for you.
</pre>
</blockquote>
<pre wrap="">
Before I wrote first mail, I checked the same with these new
versions of samba
and cifs-utils. It did not solve the problem. Anyway, thanks for the upgrade.
The problem is with realpath function, which is used in mount.cifs to
canonicalize mount point path. Two specifications are used for this function:
one assumes that the second argument is obvious pointer to the buffer for
canonicalized path, and the second allows to NULL pointer, when realpath
should malloc memory for that buffer. mount.cifs uses second form and gives
NULL pointer to this call, but for some reason (for me at least), realpath is
not accepting NULL in the second parameter and gives error. Well, only in
32-bit compilation. Maybe because of some additional packages, added myself,
cifs-utils catch invalid library? I have to find the cause or patch
cifs-utils.
</pre>
</blockquote>
<pre wrap="">
Does the version I built work for you?
</pre>
</blockquote>
<br>
Andrzej/Heiko:<br>
<br>
I wonder if this is related to the '<a
href="http://old.nabble.com/Samba-wide-links-problems%3A-canonicalize_connect_path-failed-td30728652.html">Samba
wide links problems: canonicalize_connect_path failed</a>' problem
that I reported on devil-linux-discuss on 21 Jan 2011 - and which
still persists. It certainly sounds similar. Is it possible that the
problem is caused by the location of smb.conf?<br>
</body>
</html>
|