|
From: Heiko Z. <he...@zu...> - 2006-04-10 13:47:19
|
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Hey, On Sat, April 8, 2006 17:48, Friedrich Lobenstock wrote: > Hi! > > > I'm proposing a change to etc/init.d/ startscripts, namely adding a > filesystem init routine to the start section which unpacks parts of the > /var/ filesystem if > the underlying filesystem which some daemon needs is currently empty. This > situation will happen when eg. LV 'log' gets mounted at /var/log. > > Attached is an example patch to etc/init.d/sysconfig. > > > As you can see current existing files are not overwritten. In case some > files already exist but the check determines to do the umpacking some > error messages are genereated by tar because of the already existing > files. > > Only filtering stderr (2> /dev/null) does not seem logical to me as I > wanted to show if something gets done, so I accepted the possible case of > distracting error messages. Those only say that a specific file already > existed and wasn't overwritten. > > I would add similar patches to those init script which I stumble upon and > am able to test. It's probably the time of the day, but I ask anyway... ;-) I can't see what this buys us, compared to the way we do thinks right now. - -- Regards Heiko Zuerker http://www.devil-linux.org -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.2 (GNU/Linux) iEYEARECAAYFAkQ6YckACgkQUcytMSbs+YXZewCeModZE029GWUtRF8hoEiFcbsq R/kAn2ttGr1cvw7g6lQ9BQ+qdZA6bQ6f =0YBr -----END PGP SIGNATURE----- |