|
From: Friedrich L. <fl...@fl...> - 2006-04-08 22:48:35
|
Hi! I'm proposing a change to etc/init.d/ startscripts, namely adding a filesystem init routine to the start section which unpacks parts of the /var/ filesystem if the underlying filesystem which some daemon needs is currently empty. This situation will happen when eg. LV 'log' gets mounted at /var/log. Attached is an example patch to etc/init.d/sysconfig. As you can see current existing files are not overwritten. In case some files already exist but the check determines to do the umpacking some error messages are genereated by tar because of the already existing files. Only filtering stderr (2> /dev/null) does not seem logical to me as I wanted to show if something gets done, so I accepted the possible case of distracting error messages. Those only say that a specific file already existed and wasn't overwritten. I would add similar patches to those init script which I stumble upon and am able to test. -- MfG / Regards Friedrich Lobenstock ____________________________________________________________________ Friedrich Lobenstock Linux Services Lobenstock URL: http://www.lsl.at/ Email: fl...@fl... ____________________________________________________________________ |