|
From: Roland P. <pa...@ta...> - 2004-06-26 18:50:28
|
On Saturday 26 June 2004 15:47, Heiko Zuerker wrote: > Roland Pabel wrote: > > On Saturday 26 June 2004 12:31, Roland Pabel wrote: > >>On Saturday 26 June 2004 10:13, Roland Pabel wrote: > >>>On Friday 25 June 2004 15:19, Bruce Smith wrote: > >> > >>[...] > >> > >>>Ok, I've just hit this error again and I recall what I did last time: > >>> The problem is an old depmod : > >>>root:/# /sbin/depmod -V > >>>depmod version 2.4.22 > >>>depmod: QM_MODULES: Function not implemented > > > > looks like hostap-driver is one (the only?) package that calls depmod at > > some place. the old depmod doesn't work when used on a 2.6 kernel host > > system, so it generates the QM_MODULES error. My patch removes all depmod > > calls from hostap-drivers Makefile. Seems to work, my router is just > > booting that image Roland > > There should be a couple more Makefiles which call depmod, but which > probably ignore the error. > > More critical, we call depmod in the build-iso script, which is rather > important. We probably have to check if the host os is running under 2.6 > and then use either the modutils or module-init-tools depmod. > But are those dependency files then running under 2.4? /lib/modules/2.4.26/modules.dep looks ok and seems to work, but I don't know how it's created... neither the lfssystem depmod nor the compiled depmod binary from modutils package don't work on my host linux, of course it works after you booted the image... and the modules.dep file on the cd is just 80KB big, a 'depmod -an' gives a 300KB size file... Roland -- ICQ UIN 49339118 Linux Counter #88774 GPG-Key 1024D/59C6AFA6 2003-02-07 Roland Pabel <ro...@pa...> |