Probleme beim starten des Servers: "oracle

Oosho
2004-07-15
2004-07-18
  • Oosho

    Oosho - 2004-07-15

    Beim starten des Compiere Servers bekomm ich folgende Meldung:

    Hat jemand eine Idee ?

    DANKE !

    2004-07-15 07:40:38,804 DEBUG [org.compiere.acct.FactLine] save FactLine=[319:107,Account=[231,Client=11,Org=11,Acct=742],Cur=100, DR=765.0|765.0, CR=0|0]
    2004-07-15 07:40:38,965 ERROR [org.compiere.model.MSequence] getNextID
    java.sql.SQLException: ORA-00907: missing right parenthesis

    at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:124)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:304)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:271)
    at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:622)
    at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:180)
    at oracle.jdbc.driver.T4CPreparedStatement.execute_for_rows(T4CPreparedStatement.java:542)
    at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1027)
    at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:2887)
    at oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:2959)
    at oracle.jdbc.driver.UpdatableResultSet.execute_updateRow(UpdatableResultSet.java:2373)
    at oracle.jdbc.driver.UpdatableResultSet.updateRow(UpdatableResultSet.java:1512)
    at org.compiere.model.MSequence.getNextID(MSequence.java:90)
    at org.compiere.util.DB.getNextID(DB.java:1869)
    at org.compiere.acct.FactLine.save(FactLine.java:730)
    at org.compiere.acct.Fact.save(Fact.java:590)
    at org.compiere.acct.Doc.postCommit(Doc.java:440)
    at org.compiere.acct.Doc.post(Doc.java:341)
    at org.compiere.acct.Doc.post(Doc.java:287)

     
    • Yves Sandfort

      Yves Sandfort - 2004-07-15

      Um hier berhaupt was sagen zu knnen wre erstmal interessant, welche Version da installiert ist, ob das der erste Start des Servers ist, ob es beim Setup Probleme gab etc. etc.

      Yves Sandfort
      - ComDivision -

       
    • Oosho

      Oosho - 2004-07-18

      Sorry, ja das sind zuwenig Angaben...

      Habe folgendes Setup:
      Einen DB Server (RedHat) mit Oracle9i2, ein Compiere Server (Windows 2000, Compiere 2.5.1b) mit den Oracle Client Tools und den eingerichteten Listener auf den DB Sever. Hab auf das Compiere Setup ausgefhrt (Run_Setup.bat, Run_Env.bat, Run_CompiereImport.bat, Run_Env.bat) und hab dort nirgends einen error bekommen, nur beim run_env. meinte er ich htte java 1.4.2_04 installiert und should be 1.4.1, aber auf der Installation seite steht als Requirement 1.4.2 (?).

      Dann wenn ich also das erste mal den Server starten will, (Run_Server.bat) dann kommt diese Exception.

      DANKE
      martin

       
      • Yves Sandfort

        Yves Sandfort - 2004-07-18

        Okay habe zwei Ideen, entweder es liegt an der getrenten installation von Compiere Server und DB Server.

        Oder es ist ein Fehler, der bereits gefixt wurde:

        Habe das gerade mal mit der 2.5.1d ausprobiert mit zwei servern, da hatte ich diesen Fehler so nicht...

        Das mit dem Java kannst du ignorieren.

        Yves Sandfort
        - ComDivision -

         

Log in to post a comment.