sound under colinux

Roman
2004-03-31
2004-09-08
  • Roman

    Roman - 2004-03-31

    Hi, all!
    I'm running colinux v0.6.0 under XPPro with gentoo rootfs.
    Is it possible to play sounds under colinux?

     
    • Yu Wang

      Yu Wang - 2004-04-22

      I believe you will be interested in following two projects:

      http://www.liquid-reality.de/main/projects/esound

      http://www.jcraft.com/jesd/

      Enabling Esound daemon under your coLinux which is transparent to the network will allow you to hear sound in Windows environment.

       
    • Martin Kanich

      Martin Kanich - 2004-04-26

      Well, did you tried it? i couldn't get it working. i mean the native one gets the whole CPU-Time and delivers not so good sound or no sound (using snapshot 20040424_2, debian-unstable, kde 3.2.x with esound on pentium4, winxp).
      the java clone says - not implemented :-)
      so maybe using NAS could give some boost - but not working, too

       
    • Anonymous - 2004-04-26

      Worked for me. Native esd takes hardly any processor time on amd 1900+ xp home  running fedora with xfce4 and vnc for viewing desktop.  Running stuff like xmms caused no problems at all other than some glitches caused by me using processor intensive stuff in windows at the same time.

       
      • Chris Friedl

        Chris Friedl - 2004-06-11

        I'd like to get sound working but don't know how. I assume I can load a module at boot time but how do I get the module? I'd appreciate any tips, a link etc. (I'm successfully running CL0.61 on W2K Gentoo)

         
        • Martin Kanich

          Martin Kanich - 2004-06-14

          Well i use KDE's Arts with esound. just select in KDE that you use esound instead of autodetect, set the address of you windows box. and do a test.
          it works for me with that native esound, not with java one (should be installed under windows). but it breaks the connection after a while, so it isn't the best choice. maybe it's because of those networking problems - i don't know. but for the test it should be enough.

           
          • Ken Lux

            Ken Lux - 2004-08-29

            Where do you set the IP address?????

            I've tried putting it in the box override device location:

            192.168.0.1:16001

            on clicking apply I get :

            Sound server informational message:
            Error while initializing the sound driver:
            Couldn't connect to server
            The sound server will continue, using the null output device.

            I assume it means artsd, but if I try that I get an error saying it can't find an alsa sound card.

            running esd on winxp "esd -public -tcp -promiscuous -port 16001"

            I don't get Jack!!

             
    • Android808

      Android808 - 2004-07-15

      I'm trying to get esound working but with no success.  I've emerged it in CoLinux and installed the necessary files in Cygwin, however by typing details at the command line or going into the Sound Server configuration tab in the Control Center I cant get it to recognise.
      On loading KDE it states the there is no /dev/dsp, which I already know why.  In the control center esound does not appear as an option.  I have autodetect, threaded, no i/o and open sound system or something similar

       
      • Martin Kanich

        Martin Kanich - 2004-07-16

        Hi,

        i didn't tried cygwin's esd, but that windows one works. well, if you have the actual esound for linux from freshmeat, you don't get a disconnect from it after a while, which is useful, but it works without it (with debian-unstable's one), too.
        I configured KDE to use esound, you have to install that part of KDE, that covers esound and configure your host as target. don't try to use autodetect.

        Regards,
        Martin

         
    • SKroWL

      SKroWL - 2004-07-21

      ESD -tcp -public is running on my windows machine (made the sound when starting and everything).  My debian-based coLinux is up and running.

      I'vs set Enlightened Sound Daemon as a the audio device in my KDE control panel > sound server.  I've exported ESPEAKER={mywindowip}:16001.  Not working.  If you got it working with KDE (not just on an app-by-app basis), what did you put in each box to get it working?  No matter what I do, when I apply, I get "Couldn't connect to server".

      I've checked the FAQ and the Wiki, but there are no CLEAR step-by-step instructions.

       
    • Android808

      Android808 - 2004-07-30

      What part do u have to install for kde.  I emerged kde-base and I've emerged the set containing kopete.  I would think it was arts, but I have that installed as part of the base packages I believe.

       
    • Android808

      Android808 - 2004-09-03

      Ok, I've recompiled KDE, now running 3.3, and have compiled it with esd support.  I now get the option to use EsounD as the output device for aRts.
      I have managed to get the "Couldn't connect to server" message to disappear by setting the additional parameters to --server=host.ip.add.ress:port.  As a test I have tried to play back some of the system sounds through the Control Center and a Shoutcast stream through XMMS using the xmms-arts output plugin.  Nothing happens in the control center, XMMS gives error about lack of soundcard/already in use.

       
    • Android808

      Android808 - 2004-09-03

      Ok, Problem solved.

      Start esd under Cygwin first, using:

      esd -tcp -port xxxxx -public

      Changing xxxxx to the desired value.  Open the Control Center, click on "Sound and Multimedia" then "Sound System".  Enable networked sound from the "General" tab then click on the "Hardware" tab.

      Set the audio device to "Enlightened Sound Daemon", leave everything else unchecked except the custom options which I set to:

      server=ip.address.of.host:port tcp

      I have tested it using the "Test Sound" feature under general and using XMMS playing a shoutcast stream.  If you encounter any issues, simply restart aRts.  One way is to check and uncheck one of the settings and then click OK.  There is a distinct delay at the moment, as XMMS, aRts and esound are buffering the sound, something to just play around with to make it better.

      I have also wrote a small guide on getting apps to work with esound here (same can be applied to aRts I believe using artsdsp):

      http://www.linuxformat.co.uk/modules.php?op=modload&name=phpBB_14&file=index&action=viewtopic&topic=9080&forum=1

       
    • Android808

      Android808 - 2004-09-08

      I couldn't get this to work with the FC1 image as Arts is not compiled with ESD support.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks