#2 .deb packages severly broken

open-fixed
Mathijs
None
9
2010-02-07
2010-02-05
Anonymous
No

Hi,

the new .deb packages are seriously broken. If I download them this happens:

alexander@alexander:~$ mkdir coverflow
alexander@alexander:~$ file-roller --extract-to=coverflow banshee-extension-clutterflow.deb
alexander@alexander:~$ ls -A1 coverflow/
control.tar.gz
data.tar.gz
debian-binary

Everything alright so far, but...

alexander@alexander:~$ mkdir data
alexander@alexander:~$ file-roller --extract-to=data/ coverflow/data.tar.gz
alexander@alexander:~$ ls -A1 data/
Banshee.ClutterFlow-0.3.5-r35-binaries.tar.gz
banshee-extension-clutterflow.deb
.config
make_package
usr

That shouldn't look like this, should it?

Alexander Kurtz <kurtz.alex@googlemail.com>

Discussion

  • Mathijs
    Mathijs
    2010-02-07

    • priority: 5 --> 9
    • assigned_to: nobody --> mathijsken
    • status: open --> pending-accepted
     
  • Mathijs
    Mathijs
    2010-02-07

    Yes indeed, something has gone very wrong there. And it's my fault. It basically contains the directory and all of the contents where I create my debians. I'll fix it here and upload the correct version soon.

    Thank you for reporting this

     
  • Mathijs
    Mathijs
    2010-02-07

    This should be fixed if not, do tell me

     
  • Mathijs
    Mathijs
    2010-02-07

    • status: pending-accepted --> open-fixed
     
  • Mathijs
    Mathijs
    2010-02-18

    Damn sourceforge... you're right. Removed and re-uploaded the file, should be allright now.