gpt and mbr

jack
2015-01-21
2016-12-17
  • jack

    jack - 2015-01-21

    My Dell computer died and Clonezilla-live worked on it just fine
    using Clonezilla-live v.2.2.4-12-i686-pae.iso. I have been using
    Clonezilla-live for years with minimal problems.
    I had a new computer made with a Gigabyte mb. This computer has
    fits when I run Clonezilla. I downloaded Clonezilla-live v.2.3
    .1-18-i686-pae.iso to see if it made any difference. It did not
    do anything. Windows just started. I have added the error message
    that Clonezilla gave running V.2.2.4-12-i686-pae.iso.
    It appears that there is some problem with GPT versus the MBR.
    Since I am a windows guy I have no idea what you are talking
    about in the ERROR MESSAGE below let alone fixing it. I used
    disk management to determine if the computer is using MBR or
    GPT. The computer is using MBR as far as I can tell.
    When you respond Please be specific with any instructions you
    give as I am a Windows guy and Linuz is a mystery to me.

    Here are my specs and I will supply any information you ask for.
    Windows 7 Pro 64-bit, Gigabyte MB, all windows updates, ESET SS,
    8G ram, Nvidia and Intel i5.

    ERROR MESSAGE:
    selected device [sda] found!
    the selected devices: sda
    this disk contains mismatched GPT and MBR partition: /dev/sda
    it will confuse Clonezilla and might make saved image useless or fail to clone the disk
    you can use gdisk or sgdisk to fix this issue.
    THERE is more but I think this is enough for you to see the problem.

    I would donate to Clonezilla if you would accept Paypal. My
    donation has been turned down because of Paypal.

    Sure hope someone can help me.

     
    Last edit: jack 2015-01-22
  • jack

    jack - 2015-01-23

    Please help with this problem.
    As of now I have no disaster backup.
    Other backup programs out there don't have a decent disaster backup.

     
  • Steven Shiau

    Steven Shiau - 2015-01-23

    Since your /dev/sda has mismatched GPT and MBR partition, and you mention you are sure your disk is only using MBR, you should wipe the GPT table. It's a risk, though.
    Backup important data before you continue the following steps. All the data on the disk may be gone if something goes wrong. Therefore be careful.
    1. Boot Clonezilla live
    2. Enter command line prompt
    3. sudo -i
    4. sgdisk -z /dev/sda
    (Make sure /dev/sda is the disk containing mismatched GPT and MBR partition.)
    5. reboot.

    Good luck.
    Steven.

     
    Last edit: Steven Shiau 2016-02-21
    • Kawha Yang

      Kawha Yang - 2016-02-19

      THANK YOU STEVEN! Your answer was clear and accurate. You had clear instructions telling the user exactly what to do and it worked perfect.

       
      Last edit: Kawha Yang 2016-02-19
      • Steven Shiau

        Steven Shiau - 2016-02-21

        OK, it's good to know you can follow that to solve your issue there.

        Steven.

         
    • Birtieddu

      Birtieddu - 2016-11-04

      Same problem here, this worked well! Thanks!

       
  • jack

    jack - 2015-01-23

    Thank you for answering Steven.
    I have no idea how to do this:
    "Make sure /dev/sda is the disk containing mismatched GPT and MBR partition"
    Since I have no backup I hesitate.

     
  • Steven Shiau

    Steven Shiau - 2015-01-24

    Well, this is only can be done there. It's not easy for us to make sure that for you remotely.
    So I mentioned you should backup (copy) important files, if you still want to go on.

    Steven.

     
  • jack

    jack - 2015-01-25

    I got it to work.
    It is caused by Windows 7 using the MBR in the BIOS and Windows 10 using
    GPT. Clonezilla-live doesn't like this. I doubt I will try Windows 10
    again until I can scrap Windows 7. Lost a lot of time because of this.
    Thought you might be interested.

     
  • John Greiner

    John Greiner - 2016-12-12

    As a side note, you don't actually have to reboot after you do the sgdisk -z /dev/sda
    If you go into gparted and select the drive you were going to use to save your image and unmount it, you can just do the sgdisk trick and then rerun clonezilla again without a reboot. I've done this countless times and it's been fine that way.

     
  • ndog37

    ndog37 - 2016-12-17

    As another side note it is possible to boot windows 7 as EFI, gpt disk, however you must manually disable vga in bcd and the registry, and inject a graphics driver, otherwise you will get a blank screen. So it would be possible to dual boot windows 7 and 10 with pure gpt disk.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks