#147 Can't locate Bastille/API/HPSpecific.pm in @INC

open
nobody
None
5
2008-10-17
2008-10-17
paul barnes
No

Thank you for the response on the previous 'item'.

Same install, on the same machine.

I symlinked /usr/lib64/Bastille on /usr/lib/Bastille and relauch the command, it is a little better but i have now the following pb (see below)
Thank you in advance if you have any hint!

dhcp0421:/ # bastille -x
NOTE: Using Tk user interface module.
NOTE: Only displaying questions relevant to the current configuration.
Can't locate Bastille/API/HPSpecific.pm in @INC (@INC contains: /usr/lib /usr/lib/perl5/site_perl//5.8.8/i586-linux-thread-multi /usr/lib/perl5/site_perl//5.8.8 /usr/lib/perl5/site_perl/ /usr/lib/Bastille /opt/sec_mgmt/bastille/lib /opt/sec_mgmt/bastille/lib/API /usr/lib/perl5/site_perl/5.8.8/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/5.8.8/i586-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/vendor_perl/5.8.8/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl) at /usr/lib/Bastille/IOLoader.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/Bastille/IOLoader.pm line 8.
Compilation failed in require at /usr/sbin/InteractiveBastille line 414.
dhcp0421:/ # ls -als /opt/sec_mgmt/bastille/lib /opt/sec_mgmt/bastille/lib/API
/bin/ls: /opt/sec_mgmt/bastille/lib: No such file or directory
/bin/ls: /opt/sec_mgmt/bastille/lib/API: No such file or directory

Discussion

  • paul barnes

    paul barnes - 2008-10-28

    Hello,
    I precise
    After installing Bastille-3.2.1-0.1.noarch.rpm and perl-Tk-804.027-15 on a
    SLES 10SP1, and after doing link ln -s /usr/lib64/Bastille /usr/lib/Bastille i want o launch bastille with the "bastille -x" command, and i have the following mentionned above

    I precise as well that there is no any HPSpecific.pm file on my system, and that as already said, it is not a HP-UX system....

    Thank you for any help

     
  • Nobody/Anonymous

    Is anyone maintaining this software? A missing file bug was logged against the latest version. The bug was logged 5 months ago. WTF?

     
  • Nobody/Anonymous

    I have the same API error as well. I don't see anyone actually offering any fixes to this. I am running mine on RHEL 5.3 with a previous version of Bastille installed which I upgraded. I did an rpm upgrade to this version and now this is the error I get when I try to relaunch the bastille --c. I have been searching around the web including Linuxtopia and many others and I see everyone getting this error and no one is offering a fix or a work around. Hope someone can offer help soon, RedHat cannot offer any help on this software.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks