#12 Incoming showing local extension only

open
nobody
None
5
2005-12-01
2005-12-01
No

When using the inbound callerid functionality it only
reports from the local extension and not the real
callerid.

I have put my question here before:
http://voipspeak.net/forum/index.php?topic=27.msg65

Here is the same topic with some more information:
http://sourceforge.net/forum/forum.php?
thread_id=1389754&forum_id=366330

I hope anyone can make a fix for this and share.

Discussion

  • Darren Dwyer

    Darren Dwyer - 2005-12-14

    Logged In: YES
    user_id=1351202

    yes this is my exact same problem , and yes i totally agree
    that asttapi works with AAH 1.5 but none of the aah2.*
    beta's all of which are built on asterisk 1.2

     
  • Ramon Peek

    Ramon Peek - 2006-01-24

    Logged In: YES
    user_id=1435310

    This is because of changes in the Asterisk 1.2 Manager
    Interface. AstTapi needs to be changed in order to get
    this to work.

     
  • Gary Mackay

    Gary Mackay - 2006-03-07

    Logged In: YES
    user_id=82403

    Is anyone working on this? Is there another solution if not?

     
  • Joachim

    Joachim - 2006-03-19

    Logged In: YES
    user_id=1475137

    Hi,

    there is a simple workaround. With the flag o in the dial-
    command from asterisk (dial,..........,0) works asttapi in
    the same manner as in asterisk 1.1 and the correct callerid
    is displayed.

    Joachim

     
  • Ramon Peek

    Ramon Peek - 2006-07-05

    Logged In: YES
    user_id=1435310

    With the lastest TSP-driver supporting Asterisk v1.2 from
    Kirkham systems http://www.kirkhamsystems.com/asttapi
    the problem is solved.
    Let's hope Clint at Kirkham systems uploads his source
    codes to this page.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks