#394 Shader compiler crashes on macosx 10.5

open
None
9
2012-09-20
2009-11-16
No

with the latest version of the aqsis binaries (1.6.0) with OSX 10.5.8 (plain leopard)
renderer is ok, but compiling a shader causes

dyld: Symbol not found: __ZNKSt9bad_alloc4whatEv
Referenced from: /Applications/Aqsis.app/Contents/Resources/bin/../../Frameworks/libboost_wave.dylib
Expected in: /usr/lib/libstdc++.6.dylib

I have seen a similar issue in the nabble mailing list but for Tiger. so probably it is worth noting that it happens on Leopard too.

cheers and thanks in advance

thanks in advance....

p.

Discussion

  • renderguy

    renderguy - 2009-11-16

    Thanks for the report.

    I've experienced this behaviour on Tiger and believe the cause is the same, it's to do with the way Boost (one of our dependencies) was built... not an issue with Aqsis itself.

    This will be fixed shortly and an update released (1.6.0/1.6.1).

     
  • Paolo Cignoni

    Paolo Cignoni - 2009-11-16

    Great! Thanks for the fast reply.
    We are adding Aqsys support inside MeshLab and i got stuck on that while testing the osx version of MeshLab.

    thanks again
    cheers
    P.

     
  • MM

    MM - 2011-08-29

    It seem one of our developers, from makehuman team, found a solution. Please take a look: http://code.google.com/p/makehuman/issues/detail?id=137#c7

    Best,

    Manuel Bastioni

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks