Showing 1699 open source projects for "gui in java"

View related business solutions
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 1
    The Cornell Web Lab Collaboration Server is a suite of tools and services for GUI-based extraction, analysis and sharing of archived web data. See http://weblab.infosci.cornell.edu/ and http://www.cs.cornell.edu/~weigel for details about the project.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    Java based Keytool GUI for managing certificate files. It provides a clean and simple UI to help users with their problems while working with certificate files.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    gpNoCsim++ is a Network-on-Chip simulator based on gpNoCsim that extends the gpNoCsim and adds new features such as: asynchroniztion (using multithreading), loading network traffic from file, new topologies(i.e WK-Recursive), GUI and reporting features.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 4
    A toolkit for the Clojure programming language. Including a general purpose that augments Clojure's standard library, a platform the plugin-extensible GUI applications, a simple Clojure IDE based on that platform, testing services and more.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 5
    TightVNC
    TightVNC is an improved version of VNC, great free remote-desktop tool. The improvements include bandwidth-friendly "Tight" encoding, file transfers in the Windows version, enhanced GUI, many bugfixes, and more.
    Leader badge
    Downloads: 301 This Week
    Last Update:
    See Project
  • 6
    Scriptor is a now free available Scripting Editor for C, C++, CSS, PHP, Java, Python, HTML and many more. The Project will be now regulary updated.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    JBookManager is a library management application written to make it easier to manage you library and your book orders. It has a Swing GUI and allows export to many well-known data formats like BibTeX
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Moved to GitHub http://github.com/autentia/autentia-wuija !!! WUIJA is a Java framework to develop Web apps. Our goal: make development easier. The best point: you can develop GUI in Java (like Swing) using widgets or adding easily your own ones.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    A GUI comparison tool that automates diffs detection between versions. You can record and play scenarios on two different releases of the same app (in sequential or parallel mode); jDiffChaser compares both screens and shows you the differences.
    Downloads: 1 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 10
    PGUIRobot is a very easy to use automated tool for functional and GUI testing Java programs, which can also be used for making canned demonstrations by event and screen capture.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    This is an attempt to build an Java GUI for a low cost digital storage oscilosope based on a RS232 interface.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    This is a simple app, created around an original sudoku solver based only on heuristics, not brute force. It's coded in Java/SWT(GUI toolkit). It's an example of MVC and of Visitor, Observer, Strategy, Abstract Factory, Singleton Design Patterns.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    A Java GUI that provides a means for organizers of meetup.com groups to better manage their groups.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Graphical configuration utility for Struts2 applications. This application shows struts.xml and related files in a hierarchical way and allows to manipulate all the different elements accepted in such files according to Struts2's own DTD.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15

    Mass Password Generator

    An easy-to-use generator for large numbers of passwords.

    Originally for my school's IT Department, I have now released the source code under the GNU GPL. It supports the random generation of huge numbers of passwords that can be determined in a variety of ways.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    DIET-PC (DIskless Embedded Technology Personal Computer) is a software kitset enabling IT professionals to build an open source GUI appliance based on commodity x86 (PC), PowerPC (Mac) or ARM (handheld) hardware, using an embedded Linux methodology.
    Leader badge
    Downloads: 1 This Week
    Last Update:
    See Project
  • 17
    IPv6SubnetCalc is a comprehensive calculator for IPv6 addresses. It comes with Java Swing GUI and supports the following RFCs: RFC4291, RFC4193, RFC3849, RFC2464, RFC5375, RFC4941, RFC3513, RFC3879, RFC4941, RFC3056, RFC3587, RFC2374, RFC3306, RFC3956.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    This package is a modest implementation of a non-alphanumeric encryption algorithm in java. But I'm kinda looking forward to creating a whole gui app implementing most well-known encryption tools, "the paranoid secret-coder special brainkiller"!
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    --This project is dead, someone else did it better. Search for MenuMate instead. I am writing a new app that will do the same thing as this one but with a gui instead of xml-- XML - MSG is a program that will take a special xml file and convert it into TES Script, that you can paste into the CS. It is set to default for an activator in GameMode, but you can change that yourself.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Thinlet is a GUI toolkit, a single Java class which parses the hierarchy and properties of the GUI, handles user interaction, and calls business logic. Separates the graphic design (described in an XML file) and the application methods (written as Java s
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Acelet-Scheduler with SuperScheduler and SuperWatchdog is a Java task scheduler with daemon and GUI for system and application job scheduling, can schedule tasks in a distributed environment. Holiday adjustable. Works out-box. See http://www.acelet.com
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    This is a simple Java GUI tool that lets you mindlessly enter Final Fantasy XI locked chest hints and combination responses in order to narrow down possible combinations.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 23
    PDPM is an automated time tracking & productivity measurement tool for PC/Laptop. The tool runs in the background logging usage statistics and prepares daily reports. Please see more details at http://pdpm.sourceforge.net.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 24
    COLLADA Refinery is a GUI-based application for creating content pipelines for 3D assets using modular components called conditioners. Contact a project admin to become a developer!
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    The Weblog Downloader allows users to download and archive their weblog entries in their local drives. Includes login functions to download "private" posts, option to download images, and Java GUI. Currently implemented for Xanga weblog entries.
    Downloads: 0 This Week
    Last Update:
    See Project