Showing 42 open source projects for "json-py"

View related business solutions
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 1
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using...
    Downloads: 54 This Week
    Last Update:
    See Project
  • 2
    Just-API

    Just-API

    Test REST, GraphQL APIs

    ...Supports x-www-form-urlencoded requests, Multipart requests, File uploads. Built-in Response Validation Constructs(Headers, Cookies, Status code, JSON body, JSON schema) Custom Response validator functions. Supports running custom inline or module javascript sync/async functions.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3

    TestLink-API-Python-client

    Python XML-RPC client for TestLink

    TestLink-API-Python-client is a Python XML-RPC client for TestLink Initially based on James Stock testlink-api-python-client R7 and Olivier Renault JinFeng idea - an interaction of TestLink, Robot Framework and Jenkins. TestLink-API-Python-client delivers two main classes - TestlinkAPIGeneric - Implements the Testlink API methods as generic PY methods with error handling - TestlinkAPIClient - Inherits from TestlinkAPIGeneric and defines service methods like "copyTCnewVersion" and the helper class - TestLinkHelper - search connection parameter from environment variables and command line arguments
    Downloads: 1 This Week
    Last Update:
    See Project
  • 4
    Sinon.JS

    Sinon.JS

    Test spies, stubs and mocks for JavaScript

    Standalone test spies, stubs and mocks for JavaScript. Works with any unit testing framework. As before, Sinon.JS provides utilities that help test frameworks reduce the boiler-plate. As of Sinon 10 we stopped maintaining compatibility with legacy browsers. Instead, we focus on compatibility with evergreen browsers, Node.js LTS versions and recent Safari versions. The most up-to-date reference on which runtimes and browsers we support can be found by looking at our compatibility docs. Fake...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 99.99% Uptime for MySQL and PostgreSQL Databases Icon
    99.99% Uptime for MySQL and PostgreSQL Databases

    Sub-second maintenance. 2x read/write performance. Built-in vector search for AI apps.

    Cloud SQL Enterprise Plus delivers near-zero downtime with 35 days of point-in-time recovery. Supports MySQL, PostgreSQL, and SQL Server.
    Start Free
  • 5
    VBot

    VBot

    JSON based visual regression testing library

    A visual regression testing library/tool, aims to quickly automate browser-based tests with minimum development overhead. To test flexibly in different testing scenarios, either testing against web UI wired with backends or just static web pages, VBot exposes API to be used with testing frameworks like mocha or ava, etc. Therefore, the test data variables can be updated according to different conditions, in order to decouple from real backends and avoid false negative results.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 6
    Argus Eyes

    Argus Eyes

    A lightweight commandline tool for visual regression testing of UI

    A lightweight command line tool for visual regression testing of UI components. After installing, you want to tell argus eyes which pages and which components to check for visual regression. Argus eyes work by going over a straightforward JSON file containing the resolutions you want to capture, as well as the pages with theirs url's, and the components with their CSS-selectors. Once argus eyes know where to find the components, it's time for some command line action. The first command you want to use is $ argus-eyes capture master. This makes argus eyes go over the config file and take screenshots of all specified components in there. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    Robot Framework FTP Library

    Robot Framework FTP Library

    FTP client for Robot Framework

    SOURCE CODE MOVED TO https://github.com/kowalpy/Robot-Framework-FTP-Library . NEW RELEASES WILL APPEAR ONLY AT GITHUB AND PYPI. This Python library makes it possible to test or use FTP server using Robot Framework keywords. Together with the library, there are also available project example and keywords documentation created by libdoc. This sourceforge webpage is linked from http://robotframework.org/#test-libraries as external library so it can be considered as the official Robot...
    Downloads: 2 This Week
    Last Update:
    See Project
  • 8
    Selendroid

    Selendroid

    Test automate native or hybrid Android apps and the mobile web

    ...UI elements can be found in different locator types. Same concept for automating native or hybrid apps. No modification of the app under test is required in order to automate it. Full compatibility with the JSON Wire Protocol/Selenium 3 Ready. Existing emulators are started automatically and UI elements can be found by different locator types.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 9
    Robot Framework JMeter Library

    Robot Framework JMeter Library

    Robot Framework and JMeter integration

    SOURCE CODE MOVED TO https://github.com/kowalpy/Robot-Framework-JMeter-Library . NEW RELEASES WILL APPEAR ONLY AT GITHUB AND PYPI. The Robot Framework library which can be used for starting JMeter and/or analysing and converting JMeter log files into HTML and SQLite format.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • 10

    Korat2015

    Enhanced Korat supports GUI, FSM, JUNG and JSON.

    ...Korat 2015 includes the below enhancements to Korat: - Graphical User Interface using Java Swing - Graph Output Format using JUNG (Java Universal Network/Graph Framework) - Finite State Machine Domain - Graph Archival using JSON (JavaScript Object Notation) The Wiki page has information to download, install and run Korat 2015.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 11

    ScenarLang

    A DSL that ease (shortens) the set up mockito based unit tests

    This domain specific language lets you declare complex java objects with a Json-like notation. In addition to that, it lets you specify in a natural way what the mockito mocks should return when called with a given value.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    XML Mimic
    ...Client apps that require real server for fetching xml/html responses can use this software during development and testing. Suitable for testing client application that requires any REST based web service, JSON,etc as replacement for web service server. Can also be used for any client that require HTTP based application response.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 13
    3Tpy - Telnet Testing Tool

    3Tpy - Telnet Testing Tool

    GUI based tool for running tests or configuration via telnet protocol

    3Tpy - Telnet Testing Tool is a simple Python application which main purpose is creation and execution of tests or configuration over telnet protocol. 3Tpy is released under GNU GPLv3 license. It requires Python 3.2.3 or higher. Application can be started in gui and non-gui mode. For details please read wiki.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    myjson is a small java library that operates with object literals expressed in JSON notation. It can not only convert from java objects to JSON and back, but also compare or even update a java object with the information contained in a JSON string.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 15
    AJAX and SOA Developers find it difficult to write and analyze JSON. This Eclipse plugin with the JSON2TreeView enables developers to test and visualize any JSON. Developer can enter a JSON convert it to XML and View it as a Tree.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 16
    experior

    experior

    A minimalist, powerful, language-agnostic unit/regression test tool

    Experior doesn't care what language your test program is written in. All it cares about is that each test's output begins and ends with a simple line of JSON. Your test program can validate its own output, in which case Experior just acts as a report engine. Alternatively -- or additionally -- you can write validation functions in JavaScript, and Experior will run them against the test output. Finally, Experior can compare your current test output against a copy of previous test output and alert you to regressions.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    Blackfire Player

    Blackfire Player

    Web Crawling, Web Testing, and Web Scraping application

    Blackfire Player is a powerful Web Crawling, Web Testing, and Web Scraper application. It provides a nice DSL to crawl HTTP services, assert responses, and extract data from HTML/XML/JSON responses. Some Blackfire Player use cases: Crawl a website/API and check expectations -- aka Acceptance Tests; Scrape a website/API and extract values; Monitor a website; Test code with unit test integration (PHPUnit, Behat, Codeception, ...); Test code behavior from the outside thanks to the native Blackfire Profiler integration -- aka Unit Tests from the HTTP layer (tm). ...
    Downloads: 0 This Week
    Last Update:
    See Project