Showing 1387 open source projects for "file"

View related business solutions
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 1

    JExec

    Incapsulate Java/oos features for easy usage from legacy or other lang

    ...JEsec want to be a collection of encapsultated java/oos features directly java-callable or proxied by JEsec tcp-ip service or by JEsec client caller. Example of java/OOS features not easily usable in legacy systems are: - working with PDF or Office file - calling webservices (eg. COGNOS report) - working with email - working with differents RDBS N.B. legacy/AS400 integration may be done via ILE features or via RUNJAVA/RUNQSH CL or, the simplest way, via RUNRMTCMD
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    LibDetector

    LibDetector

    EXE library detector

    With this program, you can know which libraries an EXE file needs to work.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3

    QuickREx2

    QuickREx2 Regular Expressions

    ...Additionally to the original plugin this one has a button for importing a regular expression from the editor pane. This is very helpful if the regular expression has escaped characters in the regex string. Imagine there is a Java file with a regex pattern like: "My\\s\"product\"\\scosts\\$\\d+\\.\\d{2}" To use this in the original QuickREx you have to copy the pattern, paste it into the plugins input field and remove 1 level of all the escapes: My\s"product"\scosts\$\d+\.\d{2} Using QucikREx2 this is done by mark the regex and press the import button ... done.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4

    ATG Repository Architect

    ATG Repository Modeler

    Welcome to "ATG Repository Modeler" Tool. Every one has challenge to create repository xml file in ATG. Here we are providing a GUI based tool, which has capability to create new and modify existing repository xml files. This has view of xml source for each element in repository tree.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 5

    fastest

    Automate your software testing, the fastest way!

    Fastest stands for 'Fast Automated Software test'. * This is a compilation of various open source tools complemented with a set of useful programs that help a Software Test Engineer perform the test automation with ease. * It can be envisioned as a toolkit that every test engineer would need! * Currently implemented in Java * Test Automation is not just about writing test cases in a particular programming language. There are a lot more activities that need to be accomplished in...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    httest Buddy

    httest Buddy

    Editor and Java-Wrapper for httest

    An executable Jar file contains both a Swing-based editor with syntax-highlighting, online help, example generator etc. for the "httest" tool (https://sourceforge.net/projects/htt/), as well as a Java API wrapper for writing JUnit tests with "httest".
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7

    DataSite

    Generate spring hibernate web service from database url

    Automatically generate web services to access and modify data in a database. The generated code uses spring & hibernate.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 8
    HOOPLE is a portable collection of C++ source code, featuring thread-safe objects for collections and event processing, RPC-style plugin-based encrypted networking (CROMP / octopus), bookmark collection management utilities, and a lot of other cool stuff. This is the project page for HOOPLE version 1, which was retired on September 25 2010. The code supposedly still builds on both Linux (with gnu gcc) and on Windows (with ms visual studio). Most of the code from hoople1 has moved into...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    Nen

    Nen

    neural network implementation in java

    3-layer neural network for regression and classification with sigmoid activation function and command line interface similar to LibSVM. Quick Start: "java -jar nen.jar"
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 10
    Swing GUI  Bean Form Binding
    A util toolkit which populate the back end form bean from GUI Swing component and vis versa It is intendend to be used as a lightweighted utility without importing massive of third party jar file It is flexible in a way you can add a third part GUI Swing
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Graphical OS Kernel compiled with gcc 4.6.1 and nasm 2.09.08
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    Bean Sheet is an interpreted Java spreadsheet. At its core is Bean Shell, an open source Java interpreter. The potential of marrying a Java interpreter with a spreadsheet allows a single document to be a powerful application in its own right.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 13
    IOJU

    IOJU

    generate i18n properties file, edit, get i18n object in classes

    It was merged into JCrazySuite project. http://sourceforge.net/p/jcrazysuite/ 1) Data & test class are completly separated. It makes no hardcode data in your test class. 2) Perfect mapping for data & java object(eg: POJO, POCO, Model). eg: int, boolean[], List<Double>, BigDecimal[][], YourPojo, YourPojo[], List<YourPojo>... 3) i18n object data for developer, there is no similar software component in the world up to now. 4) Ant .properties style, eg: key.my.dir=${user.dir},...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    eLML - eLesson Markup Language
    eLML (eLesson Markup Language) is an XML framework for creating structured eLessons based on a pedagogical model. eLML consists of an XMLSchema and XSLT files to create XHTML, PDF, LaTeX, IMS CP and SCORM versions, standards supported by most LMS.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    StoffelLOC is a tiny tool to count the lines of code in a single file or a whole structure. I use it for Java, JSP and JavaScript (ServerSide) files.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    File watcher tool. Look into the wiki pages for a closer description.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
    Downloads: 4 This Week
    Last Update:
    See Project
  • 18
    DataScript is a formal language for modelling binary datatypes, bitstreams or file formats. This project provides a parser and code generator for generating Java codec classes from a DataScript specification.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    DoxMentor4J is a standalone cross platform Web/Ajax based documentation library that is fully searchable and may be hosted in the file system, in an archive or embedded in the Java classpath.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Application defines templates of VHDL structures, which allows us comfortly generate most used VHDL structures. It can also work with VHDL testbench templates from which can be created VHDL testbenches of existing projects.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 21
    For Java developpers who need to request SOAP server... until SOAP is deprecated. This is a client Java API. It does not require neither perform any code generation. It fits within a single jar file. soap-dust is validated against real servers.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    jpathwatch
    A file watching facility for Java. Uses native platform support to avoid polling on selected platforms (currently supports win32, Mac OS X, Linux and FreeBSD on x86 platforms). Implements JDK 7's WatchService, but also runs on Java 5 and 6
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    BuildProcess is a set of Java tools to automatically deploy and manage application server. Each BuildProcess module is setup using a XML file. With BuildProcess, you can periodically deploy a J2EE application using JMX, delete old files, etc.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    BitcoinSuite

    BitcoinSuite

    Bitcoin GUI in Java

    BitcoinSuite is a Java based graphical user interface for Bitcoin, a peer-to-peer decentralized cryptocurrency. It is a direct fork of open source project NamecoinJ at http://sourceforge.net/p/namecoinj/. Donations are welcome: BTC: 1PqYXpLLSeAHz3FiZmPcfr451jnzsGgXbc, NMC: N2TFbwpTNhNLeXaBD8FSBbicb6guQNXUiA
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25

    knowceans

    Utility classes from maps to search engine to random samplers

    Collection of several multi-purpose Java libraries. --- knowceans-tools = collection of Java utility classes. --- Highlights: --- org.knowceans.util: IndexQuickSort, TableList: apply order of one array/list to others +++ Vectors, ArrayUtils: array convenience +++ RandomSamplers, CokusRandom, ArmSampler, Densities: random sampling and distributions +++ Arguments: command line parser +++ StopWatch, Which, ExternalProcess: runtime stuff +++ ParallelFor: OpenMP workalike +++ PatternString,...
    Downloads: 0 This Week
    Last Update:
    See Project