Showing 1790 open source projects for "embedded web server"

View related business solutions
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 1
    flow is a cross-platform headers-only C++11 framework which provides the building blocks for streaming data packets through a graph of data-transforming nodes
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
    ID3.NET MP3 Tagging Library
    ID3.NET is a set of libraries for reading, modifying and writing ID3 and Lyrics3 tags in MP3 audio files. The core library is a portable class library compatible with the .NET Framework 4 and higher, Silverlight 4 and higher, Windows Phone 7.5 and .NET for Metro style apps. It also contains non-portable libraries that provide additional platform-specific support. ID3.NET also provides an extensible metadata discovery framework that can discover specific ID3 frame data (like album art,...
    Downloads: 4 This Week
    Last Update:
    See Project
  • 3

    WebBuilder

    WebBuilder is a powerful web application development tool

    WebBuilder is a powerful rapid application development tool for creating amazing web applications. .Browser based integrated development environment. .Develop application easily and quickly. .High performance and high stability. .Cross Browser, database and operating system. .Server side script support. .Smart database access.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    foxmemo is gui-based form development tool over the web with no programming required. foxmemo is based on qooxdoo (ajax framework) on the front end. On the back-end, foxmemo relies on python (scripting), postgresql (database) and karrigell (web server).
    Downloads: 0 This Week
    Last Update:
    See Project
  • Train ML Models With SQL You Already Know Icon
    Train ML Models With SQL You Already Know

    BigQuery automates data prep, analysis, and predictions with built-in AI assistance.

    Build and deploy ML models using familiar SQL. Automate data prep with built-in Gemini. Query 1 TB and store 10 GB free monthly.
    Start Free
  • 5
    mod_pLua

    mod_pLua

    An Apache module for developing web applications using Lua

    mod_pLua is a module for the Apache httpd web server, that enables the use of preprocessed (html-embedded) Lua scripts using a PHP-like syntax as well as CGI-style interfacing, but at a much faster pace. For a more detailed description, see the wiki: https://sourceforge.net/p/modplua/wiki/
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    WaveMaker - Web Development Made Easy
    Easy-to-use, open source web development platform. Visual, drag and drop tools allow anyone to create web apps with minimal learning curve. Java architecture: Spring, Hibernate, Ajax Dojo toolkit, MySQL, PostgreSQL, HSQLDB (bundles w HSQLDB)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7

    AntiDef

    Anti defacement command line tool

    AntiDef is written in order to handle with defacement attacks. This tool written in Java in a fast-and-dirty manner; However is works. This tool is working straight forward. Server administrator should run the application with the following specific parameters: path to the copy of the web site (source), path to the application directory, path to log directory and few more optional parameters. This tool compares the source and the destination files, then copies the "defaced" files if any change occurs. The comparison occurs by default every 60 seconds, but can be defined differently. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    CafeSip - Look what Java and SIP can do

    CafeSip - Look what Java and SIP can do

    A suite of open-source tools and frameworks for creating SIP apps

    Session Initialtion Protocol (SIP) is widely used for telephone services over the Internet. CafeSip provides a suite of open-source tools and applications for creating customized SIP services and applications using the Java.
    Leader badge
    Downloads: 1 This Week
    Last Update:
    See Project
  • 9

    Java EE Two-Phase Commit Testkit

    A Portable Thin Client & Server Pair for XA / 2PC Testing

    ...The tool permits the stress-testing, performance characterization and correct transaction semantics of distributed transactions across Three XA resource managers by Exception Injection. The thin-client can be run from the command-line or inside the IDE. The server side component includes EJB packaging and some simple Web servlet support for retrieving diagnostic and performance data from the testbed.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 10
    monoMIG
    Ever wanted to use a Wii Remote, pheraps a Multitouch surface or the Microsoft Kinect to control your application/game even if web based? If so, then MonoMIG (Multi Input Gateway) is what you are looking for!
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11

    Trx Framework

    .NET project for financial messages interchange supporting ISO 8583

    Trx Framework allows to build client/server applications to interchange financial messages. It supports many encoding/decoding mechanisms for fixed and variable field messages, including ISO 8583, XML and conditional formatting. It is highly customizable and extensible. Trx Framework also provides a flexible channel communication infrastructure supporting TCP/IP and other technologies.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 12
    Dataweb Project - Java RAD Framework
    Dataweb Project is a RAD (Rapid Application Development) written in java. It's a client/server framework that allows to develop and to use tables, forms, reports, modules, plugins, services, webservices and other from remote. See project web site.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13

    .Net WCF Provider Proxy

    WCF wrapper for the Microsoft ASP.Net Providers

    This is a client/server wrapper to create a proxy between an secure application server inside a firewall and the less secure web server for the Membership, Profile, and Role providers. Although the main scenario is to enable a WCF communication channel to allow a web site to take advantage of the built-in SQL providers within a website that may not have access to the database directly, any provider meeting the provider model criteria can be used.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14

    RSS Event Manager

    Allows you to submit events to an RSS feed via rest api (http post)

    This tool was originally written to replace the massive amounts of email sent out by automated build scripts. Once this tool is deployed to a server, your scripts can simply use a HTTP Post to submit events, and users can subscribe to the RSS feed to receive updates, instead of receiving an email for each event. It is trivial to add a new feed, and using http to submit events means that firewalls are (usually) not a concern.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Porter

    Porter

    Lightweight web development server package for Windows

    Porter is portable web development server for PHP/Node/MySQL developers. Project home page - http://litporter.sourceforge.net News and info about project can be found at our Google+ page - http://gplus.to/litporter Donations are also welcome http://lit.lv/donate.php
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Easy control of virtual machines of VirtualBox (virtualization solution) on a Linux headless server. Autostart and autosave on boot/halt. Start, stop, save, backup and show status of sessions in batch mode from command line.
    Leader badge
    Downloads: 4 This Week
    Last Update:
    See Project
  • 17

    ipmiro

    PMI Romania Chapter mobile application

    A group of enthusiastic people started to work as volunteers on an interesting software project targeting mobile devices. The main scope of the project is to enable the end users accessing the PMI (Project Management Institute) Romania Chapter's resources no matter it's about of events, project management articles or job postings. The end user has been identified as a member or non-member of PMI Romania Chapter or any project management professional interested to be up-to-date with what...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18

    Stanzapper

    A Web based XMPP utility to check communication with XMPP server.

    Stanzapper 1.1 Released.. Stanzapper is also available @ http://stanzapper.appspot.com/ Stanzapper is a Web based utility built on HTML and JavaScript that allows creating a session with XMPP server on BOSH and send, receive XMPP stanzas. It's a solution to easily build XMPP stanzas and check the responses of server. This utility can be used to check various XMPP scenarios and use-cases at protocol level. It can be used to test other XMPP applications as well. ...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Single header, templatized epxression tree. Assign functors to branches and values to leaves, then call evaluate(). Requires C++11's function<T>. Optional multi-threaded evaluation is dependent on header <future>.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    VirtualBox DashBoard - PHP application for managing multiple VirtualBox server instances from a web interface. Also integrates with phpVirtualBox for host control.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 21
    Porcupine is an open-source Python based web application server that provides front-end and back-end revolutionary technologies for building modern data-centric Web 2.0 applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
    Downloads: 3 This Week
    Last Update:
    See Project
  • 23
    XMessages for Python lets you easily integrate the X-Messages spec for simple server-client messaging into web applications. See http://www.xmessages.org for more info.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    winginx

    winginx

    Local web server for PHP, Node.js, MongoDB, MySQL developers

    Downloads: 0 This Week
    Last Update:
    See Project
  • 25

    KnProxy

    Lightweight, PHP, cURL based HTTP/HTTPS Web Proxy

    Lightweight, PHP-based Web Proxy that can utilize whatever remote connecting ablities your server has to offer. It should work out of the box. No configuration needed. For educational purposes. For a full proxy (that deals with connections), see http://sourceforge.net/projects/level5/ Note: Please post bugs/questions/feature requests on the Tracker or Forum.
    Downloads: 0 This Week
    Last Update:
    See Project