Showing 265 open source projects for "embedded linux"

View related business solutions
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 1

    PyLoris

    A protocol agnostic application layer denial of service attack.

    PyLoris is a scriptable tool for testing a server's vulnerability to connection exhaustion denial of service (DoS) attacks. PyLoris can utilize SOCKS proxies and SSL connections, and can target protocols such as HTTP, FTP, SMTP, IMAP, and Telnet.
    Leader badge
    Downloads: 30 This Week
    Last Update:
    See Project
  • 2
    lilli CMS
    The lilli CMS system is designed for small websites operated by one or a few persons. It is written in PHP and requires no database. - - - Das lilli CMS-System ist für kleine Internetseiten gedacht, die von einer oder wenigen Personen betrieben werden. Es ist in PHP geschrieben und erfordert keine Datenbank.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    POCO C++ Libraries

    POCO C++ Libraries

    Cross-platform C++ libraries with a network/internet focus.

    NOTE: Current source code as well as bugs/patches are on GitHub: https://github.com/pocoproject/poco/ C++ class libraries for network-centric, portable applications, integrated perfectly with the C++ Standard Library. Includes network protocols (Sockets, HTTP, FTP, SMTP, POP3, etc.), SQL database access and XML parsing. Licensed under Boost license.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 4
    The ftp4j library implements a Java full-featured FTP client. With ftp4j embedded in your application you can: transfer files (upload and download), browse the FTP site (directory listing), create, delete, rename and move directories and files.
    Downloads: 6 This Week
    Last Update:
    See Project
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 5
    phpMyBitTorrent: BitTorrent Tracker written in PHP. Features include: hosting torrents from remote trackers, DHT, Compact Announce, alternate links (eD2K, Magnet), HTTP-Basic Authentication, Passkey Authentication, embedded HTML Editor, Mass-upload of to
    Downloads: 1 This Week
    Last Update:
    See Project
  • 6
    JSSP (JavaScript Server Pages) enables you to generate web pages with JavaScript on Java web servers. It supports all existing Java packages and features embedded SQL commands. Includes Dervish, a JavaScript interoperability package that simplifies AJAX.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    ModSecurity is a web application firewall that can work either embedded or as a reverse proxy. It provides protection from a range of attacks against web applications and allows for HTTP traffic monitoring, logging and real-time analysis.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 8
    Ikoru is a platform for collaborative tagging Web applications. It has an embedded Soap/HTTP server (C++) and an user interface (AJAX). It evolved out of a study on Emergent Semantics and received funding from the EU IST project TAGora.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    SMTP4PHP

    SMTP4PHP

    PHP powerful tool for sending e-mails fast and easily

    SMTP4PHP is a collection of PHP classes, dedicated for composing and sending multipart/mixed email messages quickly and easily, with or without embedded images and/or attachments.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Earn up to 16% annual interest with Nexo. Icon
    Earn up to 16% annual interest with Nexo.

    Access competitive interest rates on your digital assets.

    Generate interest, borrow against your crypto, and trade a range of cryptocurrencies — all in one platform. Geographic restrictions, eligibility, and terms apply.
    Get started with Nexo.
  • 10
    Jepp (Java Embedded Python) embeds CPython in Java. It is stable and thread-safe, and is suitable for many different scripting needs. Note: for most purposes Jep is now at https://github.com/mrj0/jep Releases can be found on pypi: https://pypi.python.org/pypi/jep/3.1.0
    Downloads: 1 This Week
    Last Update:
    See Project
  • 11
    Flame Cms Project

    Flame Cms Project

    FLAME-CMS es un gestor de contenidos para principiantes

    FLAME-CMS es un software libre CMS que presta una administración básica para proyectos de contenido web, donde el usuario podrá tener la posibilidad de modificar su código fuente a disposición para brindar más funcionalidades de administración dependiendo del proyecto, esta cualidad, permite que esta herramienta sea versátil para diferentes entornos en múltiples proyectos web.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    myImageClock

    myImageClock

    Displays a new image every minute according to current time.

    myImageClock will display a new image every minute according to the current time. No database required! Can be embedded into any website with configurable size options for side-column displays or as main content. Example ideas for Image Clocks; Race-Cars or Football, Players using thier numbers for the minute of the hour. Includes an Auto-Install process with assistance to secure the back-end admin area. micStarterImages.zip is REQUIRED! This 82.7MB File includes necessary...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    KCFinder
    KCFinder is an alternative to the CKFinder web file manager. It can be integrated into FCKeditor, CKEditor, and TinyMCE WYSIWYG web editors to upload and manage images, flash movies, and other files that can be embedded in generated HTML content.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 14
    Webio is a small-footprint web server, designed for embedding in an application or an embedded system. It includes a tool for generating embedded SSI and CGI routines, and a detailed programmers manual.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 15
    TinyReversProxy is a lightweight reverse proxy especially designed for embedded systems. It has been written in C language in the ESECO SYSTEMS company which builds Web3.0 and Web4.0 appliances for the domains of security and risk protection.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    DoxMentor4J is a standalone cross platform Web/Ajax based documentation library that is fully searchable and may be hosted in the file system, in an archive or embedded in the Java classpath.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    CAILogin (Counter AI Login) is an image-based user verification program for web-page logins. It's written in plain C with no special dependencies, and hence it's very suitable for embedded systems which lack "big" interpreted languages, such as PHP.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
    Downloads: 4 This Week
    Last Update:
    See Project
  • 19
    nwGTPv2 is free and open source implementation of GPRS Tunneling Protocol version 2 (GTPv2) or Evolved GTP (eGTP). GTPv2 is primarily used for control signalling between Serving Gateway SGW and PDN Gateway (PGW) in Evolved Packet Core (EPC).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Yaddns is a small ddns client with multiple ddns server supports (dyndns.org, no-ip, ovh, changeip, dyndns.it, ...) and a high flexibility. Yaddns is particularly appropriate for embedded systems. View the project homepage for more informations.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Tags embedded in HTML or other text allowing powerful data processing and simplifies web development. See http://www.trollsilm.com/mw/index.php?title=TTT
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Simple (low requirements) log viewer for use in embedded servers.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 23
    OpenL2TP is an L2TP client/server written specifically for Linux. It has been designed for use as an enterprise L2TP VPN server or for use in commercial, Linux-based, embedded networking products.
    Leader badge
    Downloads: 17 This Week
    Last Update:
    See Project
  • 24
    oneline
    Oneline provides simple, high performance platform for EC2,JDBC,Hadoop,S3,Solr,Flex, XSLT, J2EE,Windows Mobile SMS, Blog, Yahoo EMail, Google EMail, Others) and many more platform components.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    mod_layer7 is an application switching and load balancing module for Apache 2.2.x . This module utilizes mod_proxy, mod_deflate and mod_cache and contains embedded Perl interpreter that enables request rewriting and other interesting features.
    Downloads: 0 This Week
    Last Update:
    See Project