Showing 38 open source projects for "portable python mail server"

View related business solutions
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 1
    Mail-in-a-Box

    Mail-in-a-Box

    Take back control of your email with this mail server in a box

    Mail-in-a-Box helps individuals take back control of their email by defining a one-click, easy-to-deploy SMTP+everything else server, a mail server in a box. Mail-in-a-Box lets you become your own mail service provider in a few easy steps. It’s sort of like making your own gmail, but one you control from top to bottom. Technically, Mail-in-a-Box turns a fresh cloud computer into a working mail server. But you don’t need to be a technology expert to set it up. Our goals are to make deploying...
    Downloads: 8 This Week
    Last Update:
    See Project
  • 2
    Eclipse Mail

    Eclipse Mail

    eMail is a fork of Interlink for IA-32 i686 with more optimizations.

    Eclipse Mail is a fork of Interlink Mail and News made for Windows XP and runs on IA-32 i686 platforms. Some advantages over upstream and roytam1's mailnews are more optimizations and better interoperability with upstream. (using SQL storage intead of DBM)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3
    Modoboa

    Modoboa

    Mail hosting made simple

    ...Modoboa is developed with modularity in mind, expanding it is really easy. Actually, all current features are extensions. It is written in Python 3 and uses the Django, jQuery and Bootstrap frameworks. Follow the evolution of your server traffic thanks to a few builtin graphics: messages distribution per type and average size. Easily use standard protocols like DKIM or DMARC to improve your sender reputation and so make sure your emails will be delivered. Consult your emails everywhere thanks to simple but functional builtin webmail.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 4
    Fetchmail - the mail-retrieval daemon

    Fetchmail - the mail-retrieval daemon

    Client daemon to move mail from POP and IMAP to your local computer

    Fetchmail is a mail retrieval daemon that can download messages from POP3, IMAP, ODMR and ETRN-based stores, with SSL/TLS security including certificate verification, and pass downloaded mail to a local SMTP or LMTP server, or a message delivery agent such as maildrop.
    Leader badge
    Downloads: 465 This Week
    Last Update:
    See Project
  • 99.99% Uptime for MySQL and PostgreSQL Databases Icon
    99.99% Uptime for MySQL and PostgreSQL Databases

    Sub-second maintenance. 2x read/write performance. Built-in vector search for AI apps.

    Cloud SQL Enterprise Plus delivers near-zero downtime with 35 days of point-in-time recovery. Supports MySQL, PostgreSQL, and SQL Server.
    Start Free
  • 5
    An extremely configurable portable GUI email and news client for Windows/Unix (including OS X) with IMAP, POP3, SMTP, and NNTP support, SSL, flexible address database, Python scripting, powerful filtering, and many other features for advanced users.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    Bubbles

    Bubbles

    Bubbles the simple, easy to use HTTP web server, browser controlled

    Bubbles the simple, easy to use HTTP web server that is browser controlled, and capable of serving static files over the internet, either streamed from disk, or direct from RAM without lag. A GUI administration panel is accessed through your web browser (e.g. "http://localhost:1080/admin/" + default password of "admin"), which controls all her settings and vital functions, all in real time. Apart from serving files, she is capable of tracking site visits (site counters), receiving...
    Leader badge
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7
    MailCleaner

    MailCleaner

    Anti Spam SMTP Gateway

    MailCleaner Open Source Edition is now discontinued but will continue under the spamtagger project https://github.com/SpamTagger [antispam] MailCleaner is an anti-spam / anti-virus filter SMTP gateway with user and admin web interfaces, quarantine, multi-domains, multi-templates, multi-languages. Using Bayes, RBLs, Spamassassin, MailScanner, ClamAV. Based on Debian. Enterprise ready. MailCleaner is an anti spam gateway installed between your mail infrastructure and the Internet. It...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 8
    Meqaris

    Meqaris

    Booking/reservation of meeting rooms/equipment with e-mail invitations

    Meqaris (Meeting Equipment and Room Invitation System) is a system that allows booking meeting/conference rooms and other equipment or resources (like mobile whiteboards, projectors or conference audio/video sets) by using the same type of e-mail invitations that are used to invite participants to meetings. Especially useful in corporate environments, but can be used for anything in general, even by individual users. Simply add "resource participants" to the recipient list (just like...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    OpenEMM e-mail & marketing automation

    OpenEMM e-mail & marketing automation

    software for email automation (newsletters, transaction mails, etc.)

    This is an archive for old versions of OpenEMM. You will find the latest version of OpenEMM here: https://wiki.openemm.org OpenEMM is a browser-based enterprise application for email automation like info and marketing newsletters, transaction mails or multi-stage email campaigns. OpenEMM offers tons of features for professional users, among them: a great user interface, template-based HTML mailings, automatic bounce management, mail opening and link tracking, lots of graphical realtime...
    Downloads: 3 This Week
    Last Update:
    See Project
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 10
    MailHog

    MailHog

    Web and API based SMTP testing

    Inspired by MailCatcher, easier to install. Built with Go, MailHog runs without installation on multiple platforms. Run it from Docker Hub or using the provided Dockerfile. The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using...
    Downloads: 53 This Week
    Last Update:
    See Project
  • 11

    GoodCrypto private server

    Secure mail + Tor gateway

    Protect your company's email and browsing with your GoodCrypto private server. * Protects email metadata and resists traffic analysis * Automatic encryption, decryption, and key management * All private keys stay on *your* server * Users don't change their email or browser software * Blocks web malware * Runs on your private server * Completely decentralized
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    RadicalSpam

    RadicalSpam

    Open Source Anti-Spam and Anti-Virus Gateway

    RadicalSpam is a free and open source package distributed under GPL v2, including products such as Postfix, SpamAssassin Amavisd-new, Clamav, Razor, DCC, Postgrey, Bind; providing a secure SMTP relay, ready to use with linux and docker environement. More information : http://www.radical-spam.org
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    A tool for dispatching (basically, deleting) email messages on POP3 server via Plain or SSL connection with advanced filtering capabilities.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14

    ldapsync

    A MemberAdapter and cronjob to contact an ldap server for mailman

    These are two modules: the first is a MemberAdaptor for mailman that reads a file of members for each mailing list. The other is a cronjob that contacts an ldap server and * writes an aliases file for each user that has uid and mail entries in ldap, to be used with postfix * maintains lists that are defined via ldap with GroupOfNames and write the files for the first module If the ldap server is inaccessible, the files are left in place, so mails still get delivered.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Reimplementation of mailfilter (http://mailfilter.sourceforge.net/) in Python. It filters email directly on a POP3 mail server before it is downloaded by another program. This program is aimed to run on all platforms the Python programing language suppor
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    A fake mail server that captures e-mails as files for acceptance testing. This avoids the excessive configuration of setting up a real mail server and trying to extract mail queue content. Sponsered by Wordtracker.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 17
    ZMail allows you to send email from anyone, to anyone. You can use ZMail to send fake or anonymous emails. Have fun!
    Downloads: 10 This Week
    Last Update:
    See Project
  • 18
    Server bundle of : Apache2 , MySQL , PostgreSQL , OpenSSL , Xmail , SlimFTPd Software developing triad of : PHP , Perl and Python + Apache2TriadCP , PHPmyadmin , PHPPgAdmin , AWStats , UebiMiau , PHPXMail , PHPSFTPd. All latest stables , all manuals
    Downloads: 5 This Week
    Last Update:
    See Project
  • 19
    An attempt to send a full flagged MIME based email using open relay mail servers (authentication not required). Written in Python3. Using smtplib and email liabraries TODO: Bruteforce the SMTP authentication. Support TLS.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    Postfix Log Parser in Python is a log analysis tool written in python language to get statistic reports and detect anomalous behaviours on a mail server based on Postfix and Cyrus
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    This is the first portable SMTP server for windows . the goal of this project is use mail() function in php on windows ( Apache Win32 like XAMPP , EasyPHP , ... ) . now you can have a SMTP server on your USB , CD-ROM or any of your softwares and use mail
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    xODMR is an ATRN client that let you use a mail backup service when your SMTP server don't support ODMR natively. It's an alternative to xatrn and fetchmail (but works with TLS too); runs on any platform supported by Python. Win32 binary also avail
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    Imaparch is a utility to download old mail off an IMAP mail server and store it locally in a maildir. The mail can then be deleted off the server.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    Ni!Mail is a webmail connecting to an IMAP server and using python/nevow/twisted to provide a clean and fast interface. It uses nevow livepage, a library that uses XMLHTTPRequest, to make it very dynamic.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    PyWebMail is a Python library and POP3 gateway that enable working with WebMail servers like with POP3 or IMAP mail server. Currently Mail.Com, Yahoo! Mail, Gmail, Netscape.Net, HotMail and some minor servers support is finished.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • Next