76 projects for "encryption algorithm" with 2 filters applied:

  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • Our Free Plans just got better! | Auth0 Icon
    Our Free Plans just got better! | Auth0

    With up to 25k MAUs and unlimited Okta connections, our Free Plan lets you focus on what you do best—building great apps.

    You asked, we delivered! Auth0 is excited to expand our Free and Paid plans to include more options so you can focus on building, deploying, and scaling applications without having to worry about your security. Auth0 now, thank yourself later.
    Try free now
  • 1

    Largest Generic Hash and HMAC Program

    57 Hash Functions In One Program, plus each with HMAC or KMAC

    FEHASHMAC is the largest collection of publicly known hash algorithms integrated into a command-line utility. FEHASHMAC contains a set of known test vectors and results for each algorithm such that the correct implementation for each hardware platform and compiler version can directly be verified. Currently 57 hash algorithms like sha1 sha224 sha256 sha384 sha512 and variants, sha3 and shake, all SHA3 finalists and blake3, md2 md4 md5 md6, rmd128 rmd160 rmd256 rmd320, whirl gost lash160...
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 2
     In-Browser-File-Encrypter

    In-Browser-File-Encrypter

    The source code of the In-Browser-File-Encrypter web app

    The In-Browser File Encrypter is a simple web application that enables you to securely encrypt your files directly in your browser using the AES-256 encryption algorithm in CBC mode. Check it out at: https://codepen.io/Northstrix/pen/xxvXvJL and https://northstrix.github.io/In-Browser-File-Encrypter/V1.0/web-app.html GitHub page: https://github.com/Northstrix/In-Browser-File-Encrypter The download shortcut: https://sourceforge.net/projects/in-browser-file-encrypter/files/V1.0%20%28Improved%20UI%29/V1.0%20%28Improved%20UI%29.zip/download Successfully tested in Google Chrome on Windows 11 and Fedora 40.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    HashSum is a .NET port from GNU's md5sum and sha1sum. It supports: hash algorithm selection between MD5 and SHA1 (more could be added later) and compatibility between HashSum and GNU's checksum file format
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4
    GoldBug - Encrypted Communications

    GoldBug - Encrypted Communications

    Chat Messenger. E-Mail-Client. Websearch. Filetransfer.

    GoldBug is a decentralized & secure communication suite that offers an integrated e-mail client, an instant messenger & a file transfer. Also included is an URL-RSS-DB & a p2p web search. Current vers. w/ McEliece Algorithm. GoldBug has been 2013 - 2023 ten years just another Graphical User Interface of the Spot-On Encryption Suite. Main GUI features: Minimal & colorful Interface with Tabs in the East. Microsoft & Qt MinGW deprecated Win32 & for Compiling: ● https://sourceforge.net/p/goldbug/wiki/compiling As Spot-On implemented the minimal GB-concept & Nuvola Icons, GoldBug has now been fully integrated into Spot-On Win64: Just choose Tabs at East & Mini-View in Options - w/ Nuvola Icons of course! ...
    Downloads: 7 This Week
    Last Update:
    See Project
  • Earn up to 16% annual interest with Nexo. Icon
    Earn up to 16% annual interest with Nexo.

    Let your crypto work for you

    Put idle assets to work with competitive interest rates, borrow without selling, and trade with precision. All in one platform. Geographic restrictions, eligibility, and terms apply.
    Get started with Nexo.
  • 5

    cppcrypto

    C++ cryptographic library (modern hash functions, ciphers, KDFs)

    .... - 'cryptor' - for file encryption using Serpent-256 algorithm in AEAD mode. Check out the cppcrypto web site linked below for programming documentation.
    Leader badge
    5.0 out of 5 stars 1 Review
    Downloads: 2 This Week
    Last Update:
    See Project
  • 6
    This tool can create one-time-password values based on HOTP (RFC 4226: HOTP: An HMAC-Based One-Time Password Algorithm), TOTP (RFC 6238: TOTP: Time-Based One-Time Password Algorithm) and OCRA (RFC 6287: OCRA: OATH Challenge-Response Algorithm) standards, and also supports client side of OAuth protocols (1.0a, 2.0).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 7

    AESA

    All-purpose Encryption and Security Adaptation

    Starting as a personal study project, I have decided to share this security project. For now, it is a JAVA program that can be used to encrypt and decrypt simple file content (ie files), possibly later evolving into a utility with user interface and/or a library
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    Simple program to encrypt text. Programa simple para encriptar texto.
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9

    Enfomi

    Encryption App

    Enfomi is a cross-platform standalone password-based encryption/decryption program that supports 27 algorithm variants (including AES 256bit). Archives can be self-decrypting, thus making it perfect for mobile applications.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Ship Agents Faster Icon
    Ship Agents Faster

    Transform your applications and workflows into powerful agentic systems at global scale.

    Gemini Enterprise Agent Platform lets you rapidly build, scale, govern and optimize production-ready agents grounded in your organization's data. The platform enables developers to build custom or pre-built agents for virtually any use case. New customers get $300 in free credits.
    Start Free
  • 10
    Pambaf

    Pambaf

    Another encryption algorithm

    Pambaf is a new encryption algorithm for users or developers with extremely high demands for security.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    Kirmah
    Encryption with symmetric-key algorithm Kirmah - generate keys with exotic chars - redefine key length - key mark to ensure decryption capabilities - mix data - fast with multiprocessing - possible compression - gui on gtk3 - cli tool - python3 DEPENDENCIES : ======== python3, python-gobject, gobject-introspection, pygtk 3 modes are available to encrypt : ======== - compression (full / disabled or only final step) - random (simulate a random order - based on crypted key - to randomize data) - mix (mix data according to a generated map - based on crypted key - with addition of noise) Process is as follow : ======== encrypt : file > [ compress > ] encrypt > [randomiz data > mix data > compress > ] file.kmh decrypt: file.kmh > [ uncompress > unmix data > unrandomiz data] > decrypt > [uncompress > ] file ======== for encrypt/decrypt large binary files, use the fastest alternative : split/merge
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12

    xxteac - XXTEA Encrypter/Decrypter

    xxteac - XXTEA Encrypter/Decrypter

    This xxteac program utilizes the "Corrected Block TEA" encryption/decryption algorithm by Roger Needham and David Wheeler. The original algorithm has been slightly modified to allow arbitary length passwords / password files.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 13
    ImpraStorage

    ImpraStorage

    ImpraStorage provided a private imap access to store large files

    ImpraStorage provided a private imap access to store large files. Each file stored on the server is split in severals random parts. Each part also contains random noise data (lenght depends on a crypt key) to ensure privacy and exclude easy merge without the corresponding key. An index of files stored is encrypt (with the symmetric-key algorithm Kirmah) and regularly updated. Once decrypt, it permit to perform search on the server and download each part. transfert process is...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Use of Michael Rabin's Information Dispersal Algorithm to provide secure, dispersed storage in a networked environment. For full download, please get both Math-FastGF2 and Crypt-IDA releases under the files link. See project wiki for more information.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    Fileprivacy

    Fileprivacy

    Fileprivacy easily encrypts your files

    Fileprivacy is a small tool which easily encrypts and decrypts files with common algorithms like AES, Blowfish, Triple DES and RSA. You can either use passwords or keyfiles. Since Fileprivacy is coded in Java it should run on all popular operating systems. #######BETA 2####### Bugfix - Beta 1 stopped working if filename was too short or long - added .exe file ####### NOTE ####### This is an early beta implying there are some issues left. The Keygenerator stops working if you...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    QPass password manager
    QPass is easy to use, open source password manager application with built-in password generator. You can store in it's database such data as passwords and logins which will be encrypted using AES-256 with PBKDF2(number of iterations set by user). Each entry can include additional information about entry such as name, url adress and description.
    5.0 out of 5 stars 4 Reviews
    Downloads: 4 This Week
    Last Update:
    See Project
  • 17
    Secure Hash Algorithm variant of the nist maintained Secure Hash Algorithm. this is a 1024 bit digest. Comments suggestions always welcome. Rick Removed old downloads as they are long outdated. The update is the last version I worked on. Algorithm is based on the SHA2 digest. I may work on an updated version for c++11
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    J! Secure Password Hashes
    J! Secure Password Hashes provided an easy access to all Joomla! password hash algorithms and the Drupal 7 SHA-512 hashing algorithm. Compatible: Joomla! 2.5.
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19

    ORDO vers.1.0

    AES-128, Linux, OpenBSD, Assembly-Language

    Small cryptographic command line tool for LINUX and OpenBSD (x86) completely in 32-Bit Assembly Language. ORDO encrypt/decrypt files (max. size 2 GB) with AES-128-Algorithm (Rijndael) in CBC-Mode (Cipher-Block-Chaining). No libs are included, only system-calls are used. ORDO is under BSD License.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    OhCrypt Encryption Tool
    OhCrypt lets you easily encrypt and decrypt files using some of the most popular algorithms, like AES, Blowfish and Serpent. With OhCrypt, you can secure your data with a password-based encryption algorithm through a clean and simple interface. It demonstrates state of the art of cryptology techniques, such as password hashing and salt. Ohcrypt also features self-extractable and self-destructive encrypted files
    3.0 out of 5 stars 2 Reviews
    Downloads: 1 This Week
    Last Update:
    See Project
  • 21
    My Text is Treasure
    It is a simple password manager for your PC and Smartphone. It works like a text editor and uses a strong cryptography algorithm to generate the end file.
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    puff

    puff

    Fast and Strong Data Encryption Algorithm

    svn checkout http://umcipher.googlecode.com/svn/trunk/ umcipher-read-only
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    HTTPBrute is used to calculate HTTP Digest Access Authentication as per RFC 2617. The tool will be able to perform brute force attacks to retrieve a lost password for a given Authentication response. MD5 is the only hashing algorithm implemented.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    TinyCrypt is a simple secure program for encrypting files. The core encryption code is only 76 lines of C code, based on the well known ARC4-D(768) algorithm.
    5.0 out of 5 stars 1 Review
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    Alkindus is an automated solver for short monoalphabetic substitution ciphers without word divisions.
    Downloads: 1 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • Next