New customers can spin up VMs, build with AI, and query data at no cost.
Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
Start Free
Fully Managed MySQL, PostgreSQL, and SQL Server
Automatic backups, patching, replication, and failover. Focus on your app, not your database.
Cloud SQL handles your database ops end to end, so you can focus on your app.
TinyREST allows a Java programmer to easily create a REST server without having to install a J2EE server. Creating a new server is as easy as copying the service jar, setting up a configuration file and writing your own service handler class. The resulting project can be made to start up as a service.
Annotations can now be used to write handler class and methods.
JDBC database access as well as filesystem access is allowed from the service.
Are your office documents important to you?
Are your office documents saved in different
computers?
Are your office documents accessible to all?
Are your office documents corrupted on an
off?
Are you fed up with losing important files?
Are you fed up with mis-management of
document files?
What if by mistake your office file is deleted?
What if, you create/maintain different
documents for different jobs and you can’t find
them at the time they required quickly.
What if,...
Implementation of an open source FTP Server which comply with RFC 959, RFC 2228, RFC 2389 and RFC 2428. Implemented in Java. This server can be run as a stand alone FTP server and can be easily embedded in any java project. Please visit our project h
BuildProcess is a set of Java tools to automatically deploy and manage application server.
Each BuildProcess module is setup using a XML file. With BuildProcess, you can periodically deploy a J2EE application using JMX, delete old files, etc.
Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.
Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
RedDwarf is a horizontally scalable application server for low latency apps such as online games, virtual worlds, and social networking applications. It is the official community fork for Project Darkstar, previously sponsored by Sun Microsystems.
A knowledgment management system written in Java under JBoss 4.2.3 Server, with richfaces 3.3.0BETA4. Including fileconversion from html to pdf and rich:editor component without special syntaxing.
Bluewave is an object oriented database and application server that provides a neat intuitive way to store data. Bluewave also features a powerful client and server API.