Looking for the latest version? Download RubyCocoa-1.2.0.tar.gz (2.0 MB)
Home / RubyCocoa / 1.0.5
Name Modified Size Downloads / Week Status
Parent folder
Totals: 5 Items   7.6 MB 5
RubyCocoa-1.0.5-OSX10.8.dmg 2012-10-07 1.6 MB 11 weekly downloads
RubyCocoa-1.0.5.tar.gz 2012-10-07 2.9 MB 11 weekly downloads
RubyCocoa-1.0.5-OSX10.7.dmg 2012-10-07 1.6 MB 11 weekly downloads
RubyCocoa-1.0.5-OSX10.6.dmg 2012-10-07 1.6 MB 22 weekly downloads
readme.txt 2012-10-07 1.2 kB
Hi, I am honored to announce the immediate release of RubyCocoa 1.0.5. RubyCocoa is a Mac OS X framework that allows Cocoa programming in the object-oriented scripting language Ruby. In other words, it is a bridge that let you access Objective-C objects from Ruby, and vice-versa. You can learn more about RubyCocoa on our website: http://rubycocoa.sourceforge.net/ A source tarball as well as binary installers for Mac OS X 10.8, 10.7 and 10.6 are provided. This is mostly a minor fix release, for Xcode 4 and standaloneify.rb. Installing this release using the binary installer or manually with the default build parameters won't override the system version of RubyCocoa that ships with Mac OS X, it will go in /Library while the system version is in /System. The release notes are following. Enjoy! KIMURA Wataru == Changes 1.0.5 from 1.0.4: 2012-10-07 === Improvements * project templates are upgraded for Xcode 4.2-4.5. you can install the templates with the following command. $ ruby /Developer/Documentation/RubyCocoa/Templates/install_templates.rb Xcode4.x === Fixes * Fixed standaloneify.rb not work. === Removals * osx/active_record.rb was removed.
Source: readme.txt, updated 2012-10-07