#739 templates inside wiki-tables

closed-duplicate
Jens Frank
5
2004-05-31
2004-05-28
Andre Engels
No

If the first table element in a table row starts with a
template, the result is parsed incorrectly. The }} at the
end is made part of the Template-link, and what comes
after it gets mis-parsed as well.

Discussion

  • fjarlq
    fjarlq
    2004-05-29

    Logged In: YES
    user_id=105342

    A good example of this problem is
    http://en.wikipedia.org/wiki/Cat

     
  • Logged In: YES
    user_id=863370

    maybe related to bug n 962827 ?

     
    • labels: --> Wikitext parsing
     
  • Red Wolf
    Red Wolf
    2004-05-31

    Logged In: YES
    user_id=602266

    Somewhat related; if a wiki table contains a template then
    any HTML attributes specified by the template are ignored.
    This worked fine before MediaWiki 1.3.
    e.g.

    {| {{msg:Mountain_box_start}}

    Both the WikiProject Albums and WikiProject Mountains use
    this format and now all of the infoboxes are broken for
    hundreds of articles.

     
  • Jens Frank
    Jens Frank
    2004-05-31

    Logged In: YES
    user_id=561003

    Fixed in Parser.php, rev 1.162, deployed to production.

    I'll close this bug if there's no followup until June 3.

     
  • Jens Frank
    Jens Frank
    2004-05-31

    • assigned_to: nobody --> jeluf
    • status: open --> pending-duplicate
     
  • Logged In: YES
    user_id=863370

    much better, thanks.

    There are still strange thing that happen with messages in
    tables but this problem seems to be resolved

     
  • Red Wolf
    Red Wolf
    2004-05-31

    Logged In: YES
    user_id=602266

    So you want me to open a separate problem for my issue as
    that fix did NOT fix our problem?

     
  • Red Wolf
    Red Wolf
    2004-05-31

    Logged In: YES
    user_id=602266

    Never mind. I have opened a new problem: 963647

     
  • Jens Frank
    Jens Frank
    2004-05-31

    • status: pending-duplicate --> closed-duplicate