Failed to upgrade webmin from 1.500 to latest

Webmin
Gary
2012-08-31
2013-05-22
  • Gary
    Gary
    2012-08-31

    hey there
    when i click the upgrade button i get the following:

    Failed to upgrade from www.webmin.com : RPM signature verification failed :

    rpmdb: Locker is not valid
    rpmdb: Unknown locker ID: 22
    error: db4 error(22) from db->close: Invalid argument
    error: cannot open Packages index using db3 - Invalid argument (22)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: Locker is not valid
    rpmdb: Unknown locker ID: 24
    error: db4 error(22) from db->close: Invalid argument
    error: cannot open Packages database in /var/lib/rpm
    /tmp/.webmin/209001_2_upgrade.cgi: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#11f63c51)

    Any ideas?
    Cheers
    Gary