Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#2162 Bad Model show for hdb drive

1.210
open
Jamie Cameron
5
2005-07-18
2005-07-18
Jan Grill
No

In Partition on Local Disks an SMART Drive Status
modules is for hdb drive poor showed hdc Model (CDROM
CRV-54x) instead Model of hdd drive
(WD2500SSB)connected to ide0 slave channel.
I suppose, a bug is in file fdisk-lib.pl, in section,
where is make a survey about Model off hd drive and
where is converted a Linux path to disk
/dev/ide/host0/bus0/target1/lun0 to "hdb" label. When I
change multiply value for target value from *2 to *1,
so I got proper model label for hdb in both modules.
Converted value for 0 (ie. host, bus and target are
zero) is hda, for value=1 hdb and for value=2 hdc.
I think, all expression for model inquiry is bad, but
for my use I changed 2 to 1 only and I'm satisfy.

Webmin 1.210, Mandrake 9.2 console only, hda Seagate
40GB, hdb WD 250GB, hdc CD ROM 54x.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2005-07-19

    Logged In: YES
    user_id=129364

    I would be interested to know what the file
    /proc/partitions
    contains on your system. Also, what do the files :
    /proc/ide/hda/model
    /proc/ide/hdb/model
    contain?

     
  • Jan Grill
    Jan Grill
    2005-07-19

    Asked files

     
    Attachments
  • Logged In: NO

    I have a similar problem , when i boot the server it says
    hda :attached ide-cdrom driver
    can you tell me what was done to fix this problem ?

    thank you

     
  • Logged In: NO

    I have a similar problem , when i boot the server it says
    hda :attached ide-cdrom driver
    can you tell me what was done to fix this problem ?

    thank you

     
  • Logged In: NO

    I have a similar problem , when i boot the server it says
    hda :attached ide-cdrom driver
    can you tell me what was done to fix this problem ?

    thank you

     
  • Logged In: NO

    sorry about that i only submited once , no idea why it
    shows 3 times here

     
  • Jamie Cameron
    Jamie Cameron
    2006-06-05

    Logged In: YES
    user_id=129364

    That bootup message really doesn't look like it has anything
    to do with Webmin..

     
  • Logged In: NO

    but this happened only when i installed web min , do you
    think the server trying to start from the cd rom ? but why
    after the install of the webmin only this happened ? is
    there something i have to change because i have a scsi
    drive not ide drive ,

    thank you

     
  • Logged In: NO

    jcameron
    I attached the info for the hard disk i have , i
    hope this help to find the problem ,

     
  • Logged In: NO

    jcameron
    I attached the info for the hard disk i have , i
    hope this help to find the problem ,

    [root@root]# cat /proc/partitions
    major minor #blocks name rio rmerge rsect ruse wio
    wmerge wsect wuse running use aveq

    8 0 35843686 sda 31168 46548 612590 164980 103883
    108502 1704350 1058820 0 356260 1223770
    8 1 32098 sda1 39 197 472 350 0 0 0 0 0 330 350
    8 2 104422 sda2 37 92 258 110 12 7 38 520 0 410
    630
    8 3 2040255 sda3 25 112 336 50 0 0 0 0 0 50 50
    8 4 1 sda4 5 0 10 20 0 0 0 0 0 20 20
    8 5 33664176 sda5 30900 45283 609458 163800 103871
    108495 1704312 1058300 0 355410 1222070
    8 16 78091136 sdb 667 3387 8136 1040 0 0 0 0 0 930
    1040
    8 17 32098 sdb1 40 223 528 60 0 0 0 0 0 50 60
    8 18 13687380 sdb2 14 58 144 90 0 0 0 0 0 90 90
    8 19 104422 sdb3 15 61 152 70 0 0 0 0 0 70 70
    8 20 1 sdb4 4 0 8 0 0 0 0 0 0 0 0
    8 21 25969041 sdb5 16 64 160 50 0 0 0 0 0 50 50
    8 22 522081 sdb6 15 61 152 50 0 0 0 0 0 50 50
    8 23 522081 sdb7 16 64 160 50 0 0 0 0 0 50 50
    8 24 1052226 sdb8 15 61 152 80 0 0 0 0 0 80 80
    8 25 2096451 sdb9 35 173 416 70 0 0 0 0 0 50 70
    8 32 78091136 sdc 13 19 64 20 0 0 0 0 0 20 20
    8 48 78091136 sdd 13 19 64 40 0 0 0 0 0 40 40

    [root@ root]# cat /proc/ide/hda/model
    HL-DT-STDVD-ROM GDR8163B
    [root@ root]# cat /proc/ide/hdb/model
    cat: /proc/ide/hdb/model: No such file or directory
    [root@ root]# cat /proc/ide/hdc/model
    cat: /proc/ide/hdc/model: No such file or directory

    cat /proc/scsi/scsi
    Attached devices:
    Host: scsi0 Channel: 00 Id: 00 Lun: 00
    Vendor: SEAGATE Model: ST336753LW Rev: 0006
    Type: Direct-Access ANSI SCSI
    revision: 03
    Host: scsi1 Channel: 00 Id: 00 Lun: 00
    Vendor: DELL Model: SER Rev: V1.0
    Type: Direct-Access ANSI SCSI
    revision: 02
    Host: scsi2 Channel: 00 Id: 00 Lun: 00
    Vendor: DELL Model: SER hotspare Rev: V1.0
    Type: Direct-Access ANSI SCSI
    revision: 02
    Host: scsi2 Channel: 00 Id: 01 Lun: 00
    Vendor: DELL Model: SER hotspare2 Rev: V1.0
    Type: Direct-Access ANSI SCSI
    revision: 02